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ספר זה טרם הושלם ונמצא עדיין בכתיבה.

ייתכן שחסרים בו פרקים, או אף נושאים שלמים. לפיכך, כרגע לא ניתן ללמוד ממנו על כל הנושא בצורה מקיפה.

כמו בכל אחד מהספרים, מהדפים ומהנושאים בוויקיספר, גם כאן אתם מוזמנים להוסיף את הפרקים שלדעתכם חסרים. כל פעולה שעשויה לעזור תתקבל בברכה, כולל הערות ובקשות בדף השיחה של הספר.

ספר זה כרגע נמצא בשלבי הגהה לתרגום מהגרסה מאנגלית




עדכון מצב הספר
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ברוכים הבאים לויקיספר על גימפ, תכנת קוד פתוח לעריכת תמונות. שם התכנה באנגלית, GIMP, הוא ראשי תיבות של המילים GNU Image Manipulation Program (תוכנה לעיבוד תמונות של גנו ). ספר זה יכסה כלים בסיסיים, פילטרים ותסריטים (scripts ) , ועוד נושאים מתקדמים ככל שמלאכת הכתיבה והתרגום תתקדם.

אודות הספר בעברית

	ספר זה מכוון להיות תרגום של המדריך הקיים באגלית .

	התרגום מכוון להיות שמיש וקליט יותר מנאמן למקור האנגלי, שגם הוא כרגע אינו שלם.

	למרות ששמות הכלים תורגמו, שמות התפריטים לא תורגמו בינתיים. זאת כיוון שזיהוי הכלים יכול להיעשות במהירות ע"י הצלמית המייצגת אותם, בעוד שחיפוש מילולי בשמות התפריטים תוך ניסיון לנחש את המילים המקוריות יכול להיות מייגע.

	במקומות רבים נכללו שם הכלי, אפשרות הבחירה או הגדרות הכלי באנגלית בסוגריים, מאותה סיבה.

	במקומות שנראו למתרגם כנחוצים הוספו הסברים קצרים בעיקר באשר לתרגום, אך גם באשר לשימוש. הוספו מספר פרקים שלא היו קיימים באנגלית.

	לשם תאימות וקלות חיפוש. מי שרוצה להוסיף למדריך זה חלקים שאינם קיימים באנגלית יבורך אם יקפיד להוסיף אותם תחת הפרק תרגמו אותי לאנגלית , ובכך יחסוך למשתמשים ולמתרגמים עבודה.

	דף קצר ושימושי למתחילים שאינו קיים באנגלית: טיפים להתחלת עבודה

	בימים הקרובים גרסה ראשונה מחכה רק לכם, שתציעו הגהה.

	דף מילון מונחים משמש כרגע גם להסבר מונחים ספציפיים לגימפ, וגם לציון מונחים מקצועיים שחסר עבורם תרגום הולם לעברית במדריך זה.

	דף שימושי לחיפוש נושא לפי שם בסדר אלף בית הוא: תוכן לפי סדר אלף-בית


אודות הספר באנגלית

רוב תודות לכותבי הספר המקוריים, שהצליחו לגעת במספר כה רב של נושאים, לספק הסברים קצרים ברמה גבוהה לכלים רבים של גימפ, ולספק מדריכים (Tutorials) שגם מכסים נושאים שימושיים בצורה מינימליסטית וקלילה, וגם מדגימים את השימוש בגימפ בצורה טובה עבור מי שלא התנסה בתוכנה זו בעבר. המתרגם משוכנע שספר זה יתרום הרבה למשתמשי גימפ מתחילים וברמה בינונית. ייתכן שאפילו משתמשים מתקדמים ימצאו השראה בחלק מהרעיונות במדריכים, ואולי גם "יסגרו פינות" לגבי תפקוד כלי או תוסף זה או אחר.
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ברוכים הבאים לוויקיספר של גימפ!

גימפ, או בשמו באנגלית GIMP - GNU Image Manipulation Program , הוא כלי עריכת תמונות שרשום ומופץ תחת רשיון התכנה החפשית גנו. גימפ יכול לשמש לעריכה ממוחשבת של תמונות בפורמטים רבים כגון תמונת מפת סיביות כגון צילומים. גימפ מסוגל לערוך גם תמונות בפורמט ווקטורי כגון SVG , אך בתחום זה הוא פחות מפותח מתוכנות אחרות כגון אינקסקייפ שגם היא מופצת תחת רשיון גנו, ואילוסטרייטור של אדובי. גימפ מכסה את כל פונקציות עריכת התמונה המודרניות, בכלל זה שינויי קנה מידה ופרספקטיבה, עריכת שכבות תמונה מרובות, מניפולציות צבעים, חיתוך ובחירת איזורים וכו'.

היסטוריה

פרויקט גימפ התחיל ב 1995, והגרסה הראשונה שלו (0.54) יצאה לאור בינואר 1996. 13 שנים לאחר יציאת הגרסה הראשונה, גימפ זוכה לקשת מגוונת של משתמשים מכל הגילים, מאמני גרפיקה מקצועיים ועד חובבי צילום ומחשבים, ומהווה פתרון זמין וכולל לכל מי שאינו מעוניין לשלם 700$ עבור הגרסה האחרונה של פוטושופ. מאז הגרסה הראשונה שלו, שנכתבה עבור מערכות ההפעלה יוניקס וגנו/לינוקס, גימפ יוצא למערכות הפעלה מרכזיות רבות נוספות, כולל חלונות של מיקרוסופט ו OS X של אפל.

התקנה

גימפ זקוק ל GTK , ספריית יישומונים מתקדמת שפותחה יחד עם גימפ עצמו. כדי להתקין ולהשתמש בגימפ, יש להתקין את GTK אם אינו מותקן כבר על המחשב. רוב הפצות הלינוקס המודרניות מגיעות עם GTK, אך חלונות ו OS X אינן כוללות אותו, ועבור GTK על OS X יש אף צורך בחבילת שרת X מיוחדת.

מידע נוסף בפרק הוראות התקנה

שימושיות ודוקומנטציה

ברשת קיימים מדריכים רבים לעריכת תמונות אלקטרונית, עבור גימפ ועבור תכנות עריכה אחרות. רבים מהם יכולים לשמש לעזר בעריכת תמונות בין אם נכתבו עבור תכנה זו או אחרת, כיוון שהפונקציונליות הבסיסית שרוב התכנות מאפשרות היא זהה (חיתוך, שינויי קנה מידה, צבעוניות, מחיקת והוספת פיקסלים וכו'.). משתמש גימפ ברמת נסיון בינונית יוכל לעקוב אחרי מדריך שנכתב עבור פוטושופ כאילו נכתב עבור גימפ ולחליפין, מלבד במקרים בהם נעשה שימוש באחת הפונקציות שקיימות רק באחת מהתכנות. אף על פי כן, ניסיון לעבוד עם גימפ ע"פ מדריך שנכתב לפוטושופ (או כל תכנת עריכת תמונות אחרת, למעשה) תוך ניסיון לעקוב אחרי המדריך כלשונו, במקום להשתמש בו כתכנית עבודה ולתרגם את העשייה למקבילה הגימפית - היא קשה במקרה הטוב אם לא בלתי אפשרית. למרבה הצער, לגימפ חסרות מספר תכוניות שנמצאות בשימוש נפוץ בפוטושופ כגון שכבות התאמה (שעשויות להשפיע, לדוגמה, על בהירות וניגודיות התמונה בלי לשנותן למעשה באופן קבוע) ומרחבי צבעוניות מלבד RGB ו - grayscale ( למשל CMYK שהוא חיוני, הלכה למעשה אם המטרה היא דפוס). למרבה המזל ברוב המקרים תכוניות אלו אינן עושות הרבה מלבד לקצר במקצת את תהליך העבודה, וניתן למצוא דרך חליפית לשימוש בהן ולהגיע לתוצאה זהה.

תיאור בסיסי

המראה הנוכחי של גימפ כולל 2 חלונות ראשיים - חלון התמונה וחלון הכלים. בנוסף, כברירת מחדל ישנו חלון עזרים נוסף. חלון התמונה תמיד מופיע מתחת לחלון הכלים, אך ניתן להעלים את חלון הכלים בקלות ע"י לחיצה על מקש טאב. שימו לב שלחיצה עם מקש ימני על תמונה, פותח תפריט שיש ממנו גישה לרוב הכלים של גימפ, וכמובן כל הכלים והפונקציות נגישים מסרגל הכלים שבראש חלון התמונה. בתחתית חלון התמונה מצויה שורת מצב, בה אינדיקטורים על קואורדינטות מיקום הסמן, אמת המידה של שנתות המיקום (פיקסל/מ"מ/אינטש וכו') מצב הזום (הגדלת התמונה בחלון) וכן בגרסאות מסוימות טיפים שימושיים מאוד לשימוש בכלי הפעיל, שמופיעים בהתאם למיקום הסמן בתמונה. שורת המצב גם מאפשרת התאמה ולא רק מספקת מידע על נתונים אלו. איזור חשוב נוסף הוא התפריט הראשי, ממנו אפשר להפעיל את כל הכלים והפונקציות של גימפ. בגרסאות חדשות התפריט מופיע בראש חלון התמונה, ובכל הגרסאות התפריט נגיש כאשר לוחצים קליק ימני על התמונה כאשר שום כלי רב שלבי אינו מופעל.

תוכלו לגלות עוד אודות גימפ באתר שלו : http://www.gimp.org .
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לינוקס

להפצות לינוקס השונות קיימות גרסאות גימפ כחבילה זמינה להורדה דרך מנהל ההתקנות. בנוסף, ניתן להוריד ולהתקין את הגרסה החדשה ביותר ויציבה (כלומר שאינה גרסת פיתוח) , מתוך שורת הפקודה ע"י שורה אחת. הנה רשימת הפקודות להפצות הנפוצות:

Ubuntu / Debian

משורת הפקודה, הריצו את הפקודה:


apt-get install gimp


באובונטו ייתכן ותרצו להריץ :


sudu apt-get install gimp 


ולתת סיסמת משתמש אובונטו, כרגיל.

ניתן גם להתקין את גימפ מ Software Center.

openSUSE

בהתאם לגרסת ההפצה שברשותכם תוכלו להתקין ע"י הרצה משורת הפקודה:


yast -i gimp


או:


zypper in gimp


Fedora

משורת הפקודה, הריצו את הפקודה:


yum install gimp


Mandriva

משורת הפקודה, הריצו את הפקודה:


urpmi gimp


חלונות

גרסת גימפ העדכנית לחלונות מתאימה לכל מערכת חלונות מהגרסה XP עם SP3 ואילך. כמו כן הגרסה שמקושרת כאן דורשת מעבד SSE instruction set, למשל Pentium III, Athlon XP או חזקים יותר. תוכלו לחפש באתר גימפ הרשמי גרסאות ישנות יותר ולהשתמש בהן.

	הורידו את קובץ ההתקנה של הגרסה הנוכחית לחלונות מדף ההורדה של של גימפ לחלונות באתר Sourceforge. נכון לאוקטובר 2013 הגרסה היציבה היא gimp-2.8.6. שמרו את הקובץ בספרייה שנוחה לכם, למשל על שולחן העבודה. מומלץ לא להוריד גרסאות גימפ מאתרים שאינם מקושרים ישירות ל gimp-win.sourceforge.net , שכן חלקן מכילות כל מיני תוספי תכנות חיצוניות שעשויות לגרום לתקלות.

	סגרו את כל החלונות הפתוחים והתכנות הפעילות, והקליקו פעמיים על הקובץ להרצת ההתקנה.

	ענו על השאלות בתהליך ההתקנה. אלו השאלות הרגילות, ולרוב המשתמשים אין צורך לערוך כאן התאמות וניתן להשאיר את ברירת המחדל.

	סמנו אישור שאתם מקבלים את תנאי הרישיון לשימוש בגימפ

	למשתמשים שרוצים מעט יותר התאמה, יש אפשרות לבחור "Customize". אפשר לבחור "Install now" ולהתקין את גימפ לפי ברירת המחדל. בחרו ולחצו "Next".

	"Full installation" - התקנה מלאה, תתקין את גימפ עם סביבת העבודה שלו (ללא תוספי Python). בחרו ולחצו "Next".

	תתבקשו לבחור אילו סוגי קבצים לשייך לפתיחה באמצעות גימפ. גם כאן אפשר להשאיר את ברירת המחדל. בחרו ולחצו "Next".

	תתבקשו לבחור ספריית התקנה. בחרו ולחצו "Next".

	סמנו אם ברצונכם להוסיף צלמיות הפעלה של גימפ לשולחן העבודה ולשורת ההפעלה המהירה. בחרו ולחצו "Next".

	בחנו את הבחירות שלכם. אם הכל כרצונכם, לחצו "Install"


בסיום תהליך ההתקנה תוכלו לבחור להפעיל את גימפ מיד.

הערה למשתמשי חלונות: התקנת גימפ אינה שונה מהתקנת תכנות אחרות על המחשב שלכם. הוראות ההתקנה כאן ניתנות כמו שהן, ללא אחריות על התכנה או ההתקנה. על המשתמשים לשים לב שהם מורידים את גימפ מהאתר הרשמי, ועוקבים אחרי תהליך ההתקנה שהם מבצעים כמו לכל תכנה אחרת, כולל טיפול בנושא אנטי וירוס, אם מותקן על המחשב שלהם, וכו'.

	שאלות נפוצות למשתמשי חלונות: http://gimp-win.sourceforge.net/faq.html


מק

באתר גימפ מספקים קובץ התקנה GIMP 2.8 DMG , שמספק התקנה נקייה של מערכת הבסיס של גימפ, ללא כל תוספים. הורידו אותו מכאן, ואז פתחו את הקובץ וגררו את "GIMP.app" לספריית האפליקציות.

בנוסף, קיימת גרסה למק שמגיעה עם כמה תוספים ומוצעת כאן: http://gimp.lisanet.de/Website/Download.html

מערכות אחרות

גימפ זמין גם עבור :

BSD

קיימות גרסאות גימפ עבור מערכות BSD שונות כגון OpenBSD ו - FreeBSD.

Solaris

גימפ יכול לרוץ על Solaris.

קוד מקור

ניתן למצוא את קוד המקור ומידע עליו בדפי ההורדות של האתר הרשמי של גימפ, וכן הפניות לאתרי מראה:


* http://www.gimp.org/downloads/





פרטים נוספים (אנגלית)

	חלונות http://www.wikihow.com/Install-GIMP

	כל השאר http://www.gimp.org/downloads/




  
    GIMP/כלים



[image: ]



ערכת הכלים של GIMP 2.6





גימפ מספק חלון כלים, שמאפשר נגישות ושימוש מהיר בכלים שנמצאים בשימוש הרב ביותר. חלון זה ניתן להתאמה מלאה, כלומר ניתן להוסיף ולהסיר כל אחד מהכלים בו. לשם כך יש ללכת, בתפריט הראשי ל: "Windows > Dockable Dialogues > Tools" ולבחור בכלי הרצוי.

כברירת מחדל, לא כל הכלים מוצגים בחלון - GEGL וכלי צבע אחרים הושמטו. כל הכלים נגישים מתפריט "Tools" בראש חלון התמונה. למעבר ישיר לחלון הכלים ניתן להשתמש בצירוף המקשים Ctrl + B'. גם את קיצורי המקשים ניתן לערוך, דרך התפריט בראש חלון התמונה : "Edit > Keyboard Shortcuts" . שימו לב שניתן לסמן וי בתחתית רשימת המקשים כדי שהשינוי יישמר גם אחרי שנצא מגימפ, לפעם הבאה שנשתמש בו.

כלים

אלו הכלים שנמצאים בחלון הכלים כברירת מחדל.

	צלמית
	שם
	קיצור מקשים
	תאור

	כלים לבחירה

	[image: GIMP-Toolbox-SelectionRectangle-Icon.png]
	בחירת מרובעים
	R
	בחירת ריבוע או מרובע.

	[image: GIMP-Toolbox-SelectionEllipse-Icon.png]
	בחירת אליפסואידים
	E
	בחירת עיגול או שטח אליפסואידי.

	[image: GIMP-Toolbox-SelectionLasso-Icon.png]
	בחירה חפשית (לאסו)
	F
	בחירת שטח ע"י ציור קו מתאר תוחם.

	[image: GIMP-Toolbox-SelectionWand-Icon.png]
	בחירה ערפילית (מטה קסם)
	U
	בחירת איזורים רציפים של צבע.

	[image: GIMP-Toolbox-SelectionByColor-Icon.png]
	בחירה לפי צבע
	Shift + O
	בחירת כל האיזורים בתמונה שהם בצבע המסויים שנבחר.

	[image: GIMP-Toolbox-SelectionScissors-Icon.png]
	מספריים
	I
	יצירת נתיבים לבחירת איזור.

	[image: GIMP-Toolbox-SelectionForeground-Icon.png]
	בחירת קידמת תמונה
	(none)
	בחירת איזור המכיל אובייקטים של קידמת תמונה.

	מברשות

	[image: GIMP-Toolbox-BrushBucketFill-Icon.png]
	דלי הצבע
	Shift + B
	ממלא את האיזור שנבחר בצבע או מרקם/דוגמא.

	[image: GIMP-Toolbox-BrushBlend-Icon.png]
	גרדיאנט (Gradient)
	L
	ממלא את האיזור הנבחר באפקט מעבר הדרגתי בין צבעים (גרדיאנט) לפי צורת המעבר שנבחרה.

	[image: GIMP-Toolbox-BrushPencil-Icon.png]
	עיפרון
	N
	מצייר קווים חדים. הפיקסלים אינם עוברים החלקה.

	[image: GIMP-Toolbox-BrushPaintbrush-Icon.png]
	מברשת צבע
	P
	מציירת קווים רכים. כלומר הפיקסלים עוברים החלקה או עיבוד מסויים.

	[image: GIMP-Toolbox-BrushEraser-Icon.png]
	מחק
	Shift + E
	מוחק פיקסלים משכבת התמונה הנוכחית.

	[image: GIMP-Toolbox-BrushAirbrush-Icon.png]
	מכחול אוויר
	A
	כלי ציור שמדמה מברשת אוויר, כמו מברשת "ספריי", בעל דרגות לחץ ניתנות להתאמה.

	[image: GIMP-Toolbox-BrushInk-Icon.png]
	דיו
	K
	מצייר קווים מוחלקים דמויי עט וכסת דיו.

	[image: GIMP-Toolbox-BrushClone-Icon.png]
	שכפול
	C
	מעתיק פיקסלים מחלק תמונה אחד לאחר.

	[image: GIMP-Toolbox-BrushHeal-Icon.png]
	ריפוי
	H
	מתקן אוטומטית איזורים בלתי סדירים מבחינת צבע פיקסלים.

	[image: GIMP-Toolbox-BrushPerspectiveClone-Icon.png]
	שיבוט פרספקטיבה
	(none)
	מעתיק מתמונת מקור אחרי שינוי פרספקטיבה.

	[image: GIMP-Toolbox-BrushConvolve-Icon.png]
	שזירה (Blur/Sharpen)
	Shift + U
	מחדד או מטשטש.

	[image: GIMP-Toolbox-BrushSmudge-Icon.png]
	מריחה
	S
	מורח כתמים בכוון תנועת המברשת.

	[image: GIMP-Toolbox-BrushDodgeBurn-Icon.png]
	צריבה/הטבעה
	Shift + D
	מגביר בהירות או הצללה של איזורי הצללה, גווני ביניים או איזורים מודגשים.

	כלי מתיחה וחיתוך

	[image: GIMP-Toolbox-TransformMove-Icon.png]
	הזזה
	M
	מזיז שכבות, איזורי חיתוך, וקווי רשת.

	[image: GIMP-Toolbox-TransformAlign-Icon.png]
	יישור
	Q
	מיישר או מסדר שכבות ו/או אובייקטים לשולי שכבה, או למיקום אחר.

	[image: GIMP-Toolbox-TransformCrop-Icon.png]
	קיצוץ
	Shift + C
	חותך או מקצץ את התמונה.

	[image: GIMP-Toolbox-TransformRotate-Icon.png]
	סיבוב
	Shift + R
	מסובב את ההשכבה, איזור הבחירה או הנתיב הנוכחיים.

	[image: GIMP-Toolbox-TransformScale-Icon.png]
	משנה סדר גודל
	Shift + T
	משנה סדר גודל של השכבה, איזור הבחירה או הנתיב הנוכחיים.

	[image: GIMP-Toolbox-TransformShear-Icon.png]
	גיזום
	Shift + S
	מותח את השכבה, הנתיב או האובייקט הנוכחי בכוון X או Y, וגוזם אותם.

	[image: GIMP-Toolbox-TransformPerspective-Icon.png]
	פרספקטיבה
	Shift + P
	משנה את הפרספקטיבה של השכבה, איזור הבחירה או הנתיב הנוכחיים.

	[image: GIMP-Toolbox-TransformFlip-Icon.png]
	היפוך
	Shift + F
	הופך את השכבה, איזור הבחירה או הנתיב הנוכחיים.

	כלים נוספים

	[image: GIMP-Toolbox-PathTool-Icon.png]
	נתיבים
	B
	יצירה או בחירה של נתיבים.

	[image: GIMP-Toolbox-ColourPickerTool-Icon.png]
	דוגם הצבע
	O
	בוחר צבע שמאפשר לדגום צבעים מכל אובייקט על מסך המחשב.

	[image: GIMP-Toolbox-MagnifyTool-Icon.png]
	זכוכית מגדלת (זום)
	Z
	משנה את רמת ההגדלה בה התמונה מוצגת.

	[image: GIMP-Toolbox-MeasureTool-Icon.png]
	מדידה
	Shift + M
	מציג מרחקים וזוויות.

	[image: GIMP-Toolbox-TextTool-Icon.png]
	מלל
	M
	מכניס מלל לתמונה.


בנוסף קיימים כמה כלים נוספים המוסתרים כברירת מחדל. לכלים אלו ניתן להגיע מתפריט "Tools", או ע"י הצגתם בחלון הכלים (Windows > Dockable Dialogues > Tools).




	צלמית
	שם
	קיצור מקשים
	תאור הכלי

	כלי צבע

	[image: GIMP-Toolbox-ColourColourBalance-Icon.png]
	מאזן צבע
	(none)
	משנה את מאזן הצבעים של השכבה או איזור הבחירה הנוכחיים.

	[image: GIMP-Toolbox-ColourHueSaturation-Icon.png]
	רווית צבע-גוון
	(none)
	מאפשר התאמת גוון, רווית צבע והבהירות.

	[image: GIMP-Toolbox-ColourColourize-Icon.png]
	צובע
	(none)
	מעביר את צבעוניות התמונה לסולם שחור לבן ואז מציג אותה דרך פילטר בעל צבע יחיד הניתן לשינוי.

	[image: GIMP-Toolbox-ColourBrightnessContrast-Icon.png]
	בהירות-ניגודיות
	(none)
	מאפשר התאמת בהירות וניגודיות התמונה.

	[image: GIMP-Toolbox-ColourThreshold-Icon.png]
	סף צבע
	(none)
	משנה את התמונה או איזור הבחירה הנוכחיים למפת שחור-לבן שבה איזורי לבן מייצגים פיקסלים בטווח הצבע.

	[image: GIMP-Toolbox-ColourLevels-Icon.png]
	רמות צבע
	(none)
	משנה את טווח עוצמת הצבע בכל הערוצים באיזור הבחירה.

	[image: GIMP-Toolbox-ColourCurves-Icon.png]
	עקומות צבע
	(none)
	משנה את הצבע, הבהירות, השקיפות והניגודיות של איזור הבחירה, תוך שמירה על רציפות מעברים ניתנת לשינוי.

	[image: GIMP-Toolbox-ColourPosterize-Icon.png]
	פוסטריזציה
	(none)
	מפחית את מספר הצבעים בתמונה.

	[image: GIMP-Toolbox-ColourDesaturate-Icon.png]
	מנטרל רווית צבע
	(none)
	מחליף את כל גווני הצבע בגוונים המקבילים של אפור באיזור הבחירה.

	כלים אחרים

	[image: GIMP-Toolbox-GEGLOperationTool-Icon.png]
	פעולות GEGL
	(none)
	מבצע פעולות GEGL - ספריה גרפית גנרית.


אפשרויות הכלים


[image: GIMP-Toolbox-ToolOptions-All.png]









כברירת מחדל, הפעלת כלי תציג בחצי התחתון של חלון הכלים את ההגדרות והאפשרויות לשימוש בכלי. לכל כלי יש סט אפשרויות משלו, וכל שינוי שנעשה בהן נשמר לאורך ההפעלה הנוכחית של גימפ, ויחזרו למצב ברירת המחדל של הכלי עם היציאה מגימפ.

מתחת לאפשרויות הכלי קיימים ארבעה כפתורים:

	
	[image: GIMP-Toolbox-ToolOptions-SaveOptions-Icon.png] Save options to... - שומר את השינויים שנעשו לאפשרויות הכלי לקובץ הגדרות.

	[image: GIMP-Toolbox-ToolOptions-RestoreOptions-Icon.png] Restore options from... - משחזר את השינויים שבחרנו לשמור מתוך קובץ הגדרות.

	[image: GIMP-Toolbox-ToolOptions-DeleteOptions-Icon.png] Delete saved options... - מוחק את האפשרויות ששמרנו.

	[image: GIMP-Toolbox-ToolOptions-ResetOptions-Icon.png] Reset to default values - משחזר את אפשרויות הכלי לברירת המחדל שלהן.





ניתן להסתיר את ארבעת הכפתורים ע"י לחיצה על החץ הקטן בראש אזור האפשרויות של הכלי, ובתפריט שנפתח להסיר את ה"ווי" מ Show Button Bar.

מראי צבע, כלי ותמונה פעילה


[image: ]



מימין לשמאל: תמונה פעילה, כלי פעיל ומנהל הצבע.





מתחת לערכת הכלים בחלון הכלים ניתן למקם סמנים ויזואליים שמראים את הצבע, הכלי והתמונה הפעילים באותו רגע. כברירת המחדל מוצג רק סמן הצבע. כל אחד מהסמנים האלו ניתן להצגה או הסתרה. כדי לבחור אלו מבניהם יוצגו : "Edit > Preferences > Toolbox" . תאור הסמנים בקצרה:

מנהל הצבע

סמן הצבע מראה את צבע הרקע וצבע המברשת, או אם תרצו "צבע קדמי" ו - "צבע אחורי" (באנגלית: Background color ו - Foreground color ) . הקלקה עליהם פותח את חלון בחירת וניהול הצבע. חלון זה מאפשר בחירה של צבע ומציג את פלטת הצבעים שנעשה בהם שימוש לאחרונה. בחירת צבע אפשרית ע"י מגוון הדרכים הסטנדרטיות בעורכי תמונה ממוחשבים: דגימה ישירה של צבע, בחירה ממשולש צבע או ממשטח רוויה/הצללה ועוד.

ניתן להחזיר את הצבעים לברירת המחדל שלהם ע"י הקלקה על הסמל הקטן של שני ריבועים בצד שמאל ממש מתחת לריבועי הצבע העיקריים. ניתן להשיג זאת גם ע"י לחיצה על מקש הקיצור, D .

הקלקה על הסמל הקטן בפינה העליונה למעלה, מחליפה בין צבע הרקע לצבע הקדמי. גם לכך יש מקש קיצור - X.

כלי פעיל

אזור אינדיקציה שמראה איזה כלי הוא הכלי הפעיל כרגע, וכן הגדרות רלוונטיות של מרקם/דפוס וגרדיאנט. ניתן לשנות הגדרות אלה ע"י הקלקה על תמונתם באזור האינדיקציה.

תמונה פעילה

אזור אינדיקציה שמציג תמונת אצבע של התמונה הפעילה. הקלקה על תמונת האצבע פותחת חלון בחירה שדרכו אפשר לעבור בין התמונות.



  
    GIMP/גרדיאנט



[image: ]



הגדרות ברירת המחדל של כלי הגרדיאנט.






שימוש בסיסי

[image: GIMP-Toolbox-BrushBlend-Icon.png] מקש קיצור: L

כלי עירוב צבעים (Gradient) של גימפ מאפשר יצירת גרדיאנט צבע. לדוגמה, גרדיאנט עשוי להיות משיכת מכחול או מילוי צבע שעוברים בצורה חלקה מאדום לירוק. גרדיאנט עשוי גם להיות בעל שינויי צבע חדים, וכן ניתן להפעיל את כלי הגרדיאנט על אזורי בחירה ושקיפות.

התמונה שבצד ימין מציגה את הגדרות ברירת המחדל של כלי הגרדיאנט. הנה תיאור קצר, והרחבה בהמשך העמוד:

	
	מצב - כאן ניתן להגדיר את מצב הגרדיאנט

	שקיפות - כאן ניתן להגדיר אם הגרדיאנט יהיה נראה לחלוטין או שתהיה לו שקיפות חלקית או מלאה.

	גרדיאנט - סוג הגרדיאנט

	הזחה - הגדרה באיזה מרחק מתחילת אזור הגרדיאנט הצבעים יתחילו להתמזג/להתחלף.

	צורה - צורת הגרדיאנט

	חזרה - צורת החזרה

	עידון השתנות צבע (Dithering) - עוזר בהפחתת רעש ע"י עידון השיפוע.

	דיגום מיזוג מסתגל - לעתים מאפשר לעדן את מזיגת הצבעים באזורים עם ניגודיות גבוהה. כאן אפשר להגדיר כמה שונות דרושה בין הצבעים לפני שדיגום מיזוג מסתגל יופעל, וכמה פעמים יחזור הכלי על התהליך לקבלת תוצאה באיכות הרצויה.





מצב

בעיקר האופן שבו צבעי הגרדיאנט מתקשרים עם הצבעים של שכבות אחרות תמונה, עם השכבה הנוכחית, ועם דרגות שקיפות וכו'. ניתן לייצר כאן קשת רחבה ביותר של אפקטים.

שקיפות

סרגל זה שולט בדרגת השקיפות של הגרדיאנט. כל ערך בין 0.0 ל 100.0 אפשרי, כאשר 100 הוא ערך תמונה אטומה (ללא שקיפות) ו - 0 משמעו שכבה שקופה לחלוטין. ערך ברירת המחדל הוא 100.

גרדיאנט

קיימים מאות סוגי גרדיאנטים בגימפ. ניאון, דגלים, להבות, ועוד רבים. לכל אחד מהם יש את האפקט שלו, אך מעטים מהם משתמשים בצבעים האחורי והקדמי (רקע וצבע המברשת הנוכחי). הנה תיאור קצר של גרדיאנטים אלו:

	FG to BG ‏(HSV צביעה נגד כוון השעון) - תוך שימוש במודל צביעה HVS, נע נגד כוון השעון.

	FG to BG ‏(HSV צביעה עם כוון השעון) - תוך במודל צביעה HVS, נע עם כוון השעון.

	FG to BG (RGB)‎ - משצמש במודל צביעה RGB

	FG to Transparent - מהצבע הקדמי (צבע מברשת נוכחי) אל שקיפות.


בסמוך לסוג הגרדיאנט נמצא סמל ההיפוך ([image: GIMP-Toolbox-BrushBlend-Flip.png]) . בחירת אפשרות זו תהפוך את כוון השתנות הצבע, למשל אדום לירוק בבחירת היפוך יתחלף למעבר מירוק לאדום.

הזחה

הזחת הגרדיאנט נעה בטווח של 0 עד 100% . כאשר ההזחה היא 0, השתנות הצבע מתחילה מקו התחלת האזור עליו מפעילים את הגרדיאנט. כאשר ההזחה היא 50, השתנות הצבע מתחילה מאמצע אזור הפעולה, וכו'. האזור שלפני הנקודה אליה הוזחה השתנות הצבע, ייצבעו בצבע ההתחלתי. מכאן שהגדרת ההזחה לערת 100 תגרום לכך שאיזור הגרדיאנט יהיה למעשה אזור צבע אחיד.

צורה

קיימות 11 צורות גרדיאנט, הקלקה וגרירה בתוך אזור בחירה פעיל גורם לגרדיאנט לעקוב אחרי קווי המתאר של אזור זה. צורות הגרדיאנט הן:




	לינארית - מעבר בין הצבעים בצורה חלקה משמאל לימין.

	בי-לינארית - מעבר חלק בין הצבע הראשון לשני, מהאמצע לצדדים.

	רדיאלית - מעבר צבע לינארי לאורך רדיוס, התוצאה מדמה בקירוב מה צורת ספרה (כדור).

	מרובעת - מעבר צבע בצורת מרובע, ממרכז הגרדיאנט החוצה.

	קונית (symmetrical) - מעבר לינארי עם זווית בקשת מעגלית.

	קונית (אסימטרית) - מעבר צבע לינארי בקשת מעגלית, עד הגעה לרדיוס נק' ההתחלה.

	ע"פ מתאר (זוויתית) - לשעבר shapeburst, מייצר אשליה של צורה בולטת עם פינות זוויתיות.

	ע"פ מתאר (מעוגלת) - מייצר אשליה של צורה בולטת עם פינות מעוגלות (לא בצורה מוצלחת במיוחד).

	ע"פ מתאר (עם גומות) - מייצר אשליה של צורה בולטת עם גומות (כנ"ל).

	ספירלית (בכוון השעון) - ספירלה עם כוון השעון, שמרכזה בנק' הקליק, דרגות מעבר הצבע משתנות.

	ספירלית (נגד כוון השעון) - ספירלה נגד כוון השעון.


חזרה


[image: ]



דוגמה לגל משולש (בשימוש בצורה רדיאלית).





קיימות 3 אפשרויות לחזרה:

	ללא - המעבר בין הצבעים יחיד.

	גל משונן - בסוף המעבר בין הצבעים, מתחיל מחדש בצבע הראשון.

	גל משולש - בסוף המעבר בין הצבעים, חוזר מהצבע השני אל הראשון.


ניתן להשתמש "בחזרה" עם צורות אלו: לינארית, בילינארית, רדיאלית, מרובעת, קונית סימטרית וקונית אסימטרית.

עידון השתנות צבע

אפשרות זו מפחיתה ריצוע צבע לאורך הגרדיאנט. אם ברצונך שהגרדיאנט שאתה יוצר יכיל ריצוע, הפוך אפשרות זו לבלתי פעילה. עשה כן גם במקרה שהתוצאה חייבת להיות מדויקת במיוחד (מזיגת צבעים באה על חשבון איכות רזולוציה מרחבית).

דיגום מסתגל

דיגום מסתגל מזהה אזורים בעלי דרגת ניגודיות גבוהה, ומנסה לשפר את דיוק הצגת התמונה רק בנקודות אלו. התוצאה הכללית היא החלקת אזורי הניגודיות הגבוהה. דרך אחת לראות את תוצאת האפקט הזה היא לבחון גרדיאנט משונן עם חזרות, עם ובלי הדיגום המסתגל מופעל.

האופציות בחלק זה מאפשרות שליטה ב:

	דרגת ניגודיות הסף - דרגת הניגודיות ממנה יתחיל גימפ ליישם את הדיגום המסתגל.

	כמה כוח מחשוב גימפ ישקיע לפני שיקבל ויציג את התוצאה. (ערך זה נכנס לפעולה כאשר יחס צבעי הנקודות בעלות הניגודיות הגבוהה בעצמו עולה על יחס הסף הקובע שהניגודיות גבוהה).


ראו ערך (באנגלית) supersampling למידע מפורט יותר.

ראה גם

	תיאור של קבצי GRR בספר תאוריית הצבע , כרגע קיים רק באנגלית.




  
    GIMP/הזזה



שימוש בסיסי

[image: GIMP-Toolbox-TransformMove-Icon.png] מקש קיצור: M

כלי זה משמש להזזת שכבות, אזורי בחירה, קווים מנחים, ונתיבים. הוא שימושי כאשר רוצים "לסדר מחדש" ובמהירות תמונות מורכבות, כיוון שבמצב ברירת המחדל שלו, הזזה חפשית, הוא מזיז כל אובייקט שמצביעים עליו (המסוג שאליו הוא מכוון), ולא רק את האובייקט הפעיל. לפרטים ראה החלפת מצב. להזזת אובייקט יש להצביע עליו, ללחוץ ולהחזיק עכבר שמאלי, לגרור את האובייקט למקום הרצוי ולשחרר את כפתור העכבר.

בתפריט הכלי שני כפתורי רדיו:

	הזזה (Move) - מגדיר מה יהיה האובייקט המוזז (שכבה, אזור בחירה או נתיב).

	החלפת מצב - משמש למעבר בין הזזה חופשית להזזה ממוקדת.


הזזה

כפי שנאמר למעלה, כאן ניתן להדגים מה יהיה האובייקט המוזז:

שכבות

כלי ההזזה הוא האופציה הנוחה ביותר להזזת שכבות. במצב ברירת המחדל שלו מוגדר להזזת שכבות, במצב הזזה חופשית. להזזה - הצבע על שכבה או מקבץ שכבות, לחץ עכבר שמאלי והזז את השכבה למקום הרצוי. במצב זה ניתן להזיז גם קוים מנחים (קווי רשת). כאשר הכלי מצוי במצב הזזה ממוקדת, יזיז רק את השכבה או מקבץ השכבות הפעיל. ניתן לשנות שכבה פעילה, לקבץ שכבות וכו' ב דיאלוג השכבות .

אזורי בחירה

מזיז קווי מתאר של אזורי בחירה, ללא התוכן. עבור אפשרות זו ההזזה היא תמיד ממוקדת.

נתיבים

בדומה לשכבות, מזיז נתיב או מקבץ נתיבים. ניתן להזיז נתיבים גם ע"י כלי סימון הנתיב. ניתן להחליף את הנתיב הפעיל ב דיאלוג הנתיבים

החלפת מצב

בהזזה חופשית ניתן לבחור כל אובייקט מהסוג שהוגדר ב"הזזה" ע"י הצבעה עליו עם הסמן, ואילו בהזזה ממוקדת האובייקט שיוזז הוא תמיד האובייקט הפעיל. מקש Shift מהפך (toggles) בין שני המצבים הללו.



  
    GIMP/קיצוץ
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הגדרות ברירת המחדל של כלי הקיצוץ






שימוש בסיסי

[image: GIMP-Toolbox-TransformCrop-Icon.png] Shift + C

כלי המאפשר חיתוך שוליים של אזורים מרובעים בצורה מדויקת. לשימוש בו, יש סמן את האזור שרוצים לשמור, ואז להקליק פעמיים בתוך האזור הנבחר או ללחוץ "Enter". כברירת מחדל הכלי עובד על כל השכבות יחד, אך ניתן להגדירו לעבודה על השכבה הפעילה בלבד.

	שכבה נוכחית בלבד - עבוד רק על השכבה הנוכחית.

	אפשר הגדלה - מאפשר עבודה גם מעבר לגבולות השכבה.

	פריסה מהמרכז - מגדיר את אזור הבחירה מהמרכז, במקום מהפינה.

	קיבוע - מאפשר קביעת הגודל האבסולוטי (מספרי) של שטח הבחירה.

	מיקום - מיקום השטח אותו עומדים לקצץ.

	גודל - גודל שטח הבחירה אותו עומדים לקצץ.

	הדגשה - מדגיש את שטח הבחירה שעומדים לקצץ, ע"י הצללת שאר האזורים.

	קווים מנחים - הצג קיווים מנחים בתוך אזור בחירה המיועד לקיצוץ.

	כיווץ אוטומטי - מכווץ את אזור בחירה לגודלו של האזור המרובע הקרוב ביותר למיקום השטח שנבחר, מתוך השכבה הנוכחית.

	מיזוג כיווץ - כנ"ל, בהבדל שהאזור המרובע ייבחר מבין כל אזורי התמונה הנראים ולא מהשכבה הנוכחית בלבד.


שכבה נוכחית בלבד

עבוד רק על השכבה הנוכחית, במקום על התמונה כולה.

אפשר הגדלה

מאפשר לכלי להמשיך מעבר לגבולות השכבה, ומקצץ לאורך הגבול החיצוני ביותר.

אפשרויות נוספות

כל האפשרויות האחרות של כלי זה פועלות באופן דומה לכלי בחירת המרובעים, ראה סעיפים פריסה מהמרכז עד | מיזוג כיווץ .



  
    GIMP/כלי בחירה



שימוש בסיסי


[image: ]



כל שבעת כלי הבחירה.





בגימפ קיימים 7 כלים המשמשים לבחירה. לכל כלי יש תכונות משלו, אך חלק מהתכונות משותפות כל שבעת הכלים. כל התכונות המשותפות יתוארו בדף זה, בעוד שההתאמות והשונות של יתוארו תתואר בדף של כל כלי בנפרד.

	
	[image: GIMP-Toolbox-SelectionRectangle-Icon.png] כלי לבחירת מרובעים

	[image: GIMP-Toolbox-SelectionEllipse-Icon.png] כלי לבחירת אליפסות

	[image: GIMP-Toolbox-SelectionLasso-Icon.png] כלי לבחירה חופשית (לאסו)

	[image: GIMP-Toolbox-SelectionWand-Icon.png] כלי לבחירה ערפילית l (מטה קסם)

	[image: GIMP-Toolbox-SelectionByColor-Icon.png] כלי לבחירה לפי צבע

	[image: GIMP-Toolbox-SelectionScissors-Icon.png] כלי חיתוך מספריים

	[image: GIMP-Toolbox-SelectionForeground-Icon.png] כלי לבחירת קדמת תמונה
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אפשרויות למצבי בחירה.





כלי בחירה מיוחד: כלי סימון נתיב

כלי סימון נתיב עשוי להיחשב ככלי בחירה, אך אין לו אפשרויות משותפות עם שאר כלי הבחירה. סימון נתיב יכול לשמש ככלי ליצירת אזורי בחירה מורכבים, במיוחד כאלה שמתאפיינים באזורי עקמומיות טבעית. כדי להוציא בחירה מנתיב מסומן ניתן להשתמש בקיצור המקשים Shift+V , או לחליפין בעזרת התפריט בראש חלון התמונה: Select > From Path .

בנוסף, קיים לכלי סימון הנתיב מצב מיסוך מהיר, שמשמש ליצירה ועריכה של אזורי בחירה תוך שימוש במברשת הצבע או כל כלי ציור אחר. גם למצב זה ניתן להגיע ע"י קיצור מקשים: Shift+Q או דרך התפריט בראש חלון התמונה: Select > Toggle Quick Mask .

האפשרויות המשותפות לכלי הבחירה

	
	מצבים (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת שטח חדש בכל לחיצה מחדש, או שכל שטח שיסומן יצורף לשטח שכבר מסומן וכו'.

	החלקות (Antialiasing) - גורם לאזור הנבחר להיבחר עם קווי מתאר חלקים יותר.

	קצוות נוצה (Feather edges) - גורם לאזור הנבחר להיבחר עם קווי מתאר מטושטשים.





מצבים

מצבי בחירה המאפשרים לקבוע אם השטח הנבחר יתווסף, יוחסר או ייבחר כחיתוך של שטח בחירה קודם, או שיחליף שטח בחירה קודם. בהמשך יתואר כיצד ניתן לשכפל את הפעולות שכפתורים אלו מבצעים בעזרת קיצורי מקשים. אנשים רבים מוצאים את מצבי הבחירה האלה שימושיים מאוד. מצבי הבחירה הם:

	
	[image: GIMP-Toolbox-SelectionAll-ModeReplace.png] בחר מחדש (Replace) - מצב ברירת המחדל. כל בחירה מתחילה מחדש.

	[image: GIMP-Toolbox-SelectionAll-ModeAdd.png] הוסף (Add) - כל בחירה חדשה מתווספת לשטח שכבר נבחר.

	[image: GIMP-Toolbox-SelectionAll-ModeSubtract.png] החסר (Subtract) - מסיר את השטח שנבחר משטח בחירה קודם.

	[image: GIMP-Toolbox-SelectionAll-ModeIntersect.png] חיתוך (Intersect) - השטח שייבחר יהיה השטח המשותף בין השטח החדש לשטח הבחירה הקודם.





החלקות

אפשרות זו משפיעה רק על חלק מכלי הבחירה. היא גורמת לשטח להיבחר עם קווי מתאר חלקים יותר.

קצוות נוצה

אפשרות זו גורמת לקווי המתאר של השטח שייבחר להיות מטושטשים, ע"י כך שבחירת הפיקסלים בשולי האזור היא חלקית, מדוללת ככל שמתקרבים לקו ההיקף של השטח. דבר שה מאפשר לשטחים שנבחרו כך להיטמע ויזואלית בצורה חלקה יותר ברקעים שונים, למשל.

מקשי התאמה

התנהגות כלי הבחירה ניתנת לשינוי ע"י מקשי ההתאמה Ctrl, Alt ו- Shift.

	
	Ctrl - בעל שתי אפשרויות, תלוי בפעולה המתבצעת:
	בזמן בחירת השטח, מחליף בין מצבי פריסה מהמרכז ופריסה מהפינה.

	כאשר אין מתבצעת שום פעולה, מקש זה, אם מחזיקים אותו לחוץ, גורם לכך שהבחירה שתיעשה תוך כדי, תיעשה במצב החסרה (Subtract).




	Alt - מאפשר הזזת קו המתאר של אזור הבחירה. אם ההזזה לא מתאפשרת, אפשר לנסות Shift + Alt

	Shift - בדומה ל Ctrl, גם למקש זה יש שני שימושים, תלוי בפעולה המתבצעת באותו זמן:
	לפני שקיימת בחירה, מקש זה יפעיל את מצב הוסף, כל עוד המקש לחוץ.

	לאחר שכבר קיים אזור בחירה, פעילות המקש תלויה בכלי בו נעשה שימוש באותו זמן - לדוגמה אם הכלי הנוכחי הוא "בחירת מרובעים", אם נחזיק את Shift לחוץ וניצור בחירת מרובע, הבחירה תתווסף לשטח שכבר נבחר. ניתן כך ליצור אזור בחירה המורכב מאליפסות ועיגולים.




	Ctrl + Shift' - בהתאם לכלי שבשימוש. אפשרות נפוצה היא מעבר למצב "חיתוך" אזורי הבחירה.

	Ctrl + Alt + Click-and-drag ו - Shift + Alt + Click-and-drag - מאפשר מעבר או העברה בין אזורי בחירה נוכחיים (כולל תוכן השטח)

	מקש הרווח - מקש שימושי ביותר: הופך את העכבר ל"כלי ניווט", מקבע את מיקום העכבר ומאפשר להזיז את נקודת המבט בתמונה בלי להשתמש בסרגלי הגלילה בשוליים, כל עוד המקש לחוץ . אפשר לעבור בין אפשרויות הפעולה של מקש זה ע"י שימוש בתפריט Preferences > Image Windows ולשנותו לכלי ההזזה.







  
    GIMP/בחירת מרובעים



[image: ]



ערכי ברירת מחדל של כלי בחירת מרובעים.






שימוש בסיסי

[image: GIMP-Toolbox-SelectionRectangle-Icon.png] מקש קיצור: R

כלי בחירת המרובעים הוא כלי פשוט ושימושי. כשמו כן הוא - מאפשר בחירת אזורים בעלי צורה מרובעת.




	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת מרובע בכל לחיצה מחדש, או שכל מרובע שיסומן יצורף לשטח שכבר מסומן וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.

	פינות מעוגלות (Rounded corners) - גורם לפינות המרובעים שייבחרו להיות מעוגלות, עם אפשרות לבחור את הרדיוס שלהן.

	פריסה מהמרכז (Expand from center) - בחירת המרובע תיעשה כאשר מיקום ההקלקה הראשונית הוא מרכז המרובע.

	קיבוע (Fixed) - מאפשר לקבע מראש את צורת הריבוע: פרופורציות, גובה, רוחב או גודל אבסולוטי.

	מיקום (Position) - מיקום הריבוע בקואורדינטות.

	גודל (Size) - מאפשר לבחור את גודל המרובע.

	הדגשה (Highlight) - מדגיש את האזור הנבחר ע"י הצללת האזור שמחוץ לבחירה.

	קווים מנחים (Guides) - מציג קווים מנחים שיופיעו בתוך המרובע, קיימות 4 אפשרויות: ללא קווים, חלוקה לשלישים, חלוקת הזהב, קווי אמצע.

	כיווץ אוטומטי (Auto Shrink) - מכווץ את מהרובע הנבחר לגדלו של האזור המרובע הקרוב ביותר בתמונה (ע"פ אלגוריתם בחירה "חכם").

	מיזוג כיווץ (Shrink merged) - אם אפשרות זו סומנה, הכיווץ האוטומטי ישתמש במידע מתוך צבע פיקסלים בתמונה כולה, ולא מהשכבה הפעילה.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקות למידע נוסף על החלקות.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.





פינות מעוגלות

כאשר מפעילים אפשרות זו, מופיעה שנתת בחירה שמשמשת לשינוי רדיוס מעגליות הפינות.

פריסה מהמרכז

כאשר מפעילים אפשרות זו, נקודת ההתחלה (הקלקה ראשונית) תשמש כמרכז הריבוע במקום כאחת הפינות. כתוצאה מכך פריסת המרובע היא לכל הצדדים בו זמנית. אפשרות זו ניתנת להפעלה גם ע"י מקש הקיצור Shift.

קיבוע

מאפשר לקבע מראש את צורת הריבוע: באחת מארבע אפשרויות: פרופורציות אורך/גובה, גובה אבסולוטי (כלומר גודל מספרי קבוע), רוחב אבסולוטי, או גודל אבסולוטי.

	
	פרופורציות אורך/גובה (Aspect ratio) - מאפשר לעצב את אזור הבחירה תוך שמירה על פרופורציות קבועות. כברירת המחדל יחס הפרופורציה הוא 1:1 , כלומר ריבוע. בצד יש שתי צלמיות שמאפשרות לעבור בין תמונה רוחבית (landscape ) לאורכית (portrait).

	רוחב (Width) - מאפשר לקבע את רוחב המרובע.

	גובה (Height) - מאפשר לקבע את גובה המרובע.

	גודל (Size) - מאפשר לקבע גם את רוחב וגם את גובה המרובע.





מיקום

ניתן להשתמש באפשרות זו למיקום אזור הבחירה בתמונה, לפי קואורדינטות. המיקום נעשה ע"פ הפינה השמאלית העליונה, או לפי מרכז הריבוע אם האפשרות "פריסה מהמרכז" נבחרה.

גודל

ניתן להשתמש באפשרות זו לקביעה מראש או שינוי ישיר של גודלו של אזור הבחירה בתמונה.

הדגשה

מדגיש את האזור הנבחר ע"י הצללת האזור שמחוץ לבחירה ב"מסכה" כהה, דבר המאפשר הבחנה ויזואלית קלה יותר בין האזור שנבחר לשאר התמונה.

קווים מנחים

כאן ניתן לבחור אם יופיעו קוים מנחים על אזור המרובע. קיימות ארבע אפשרויות הלקוחות מתוך העקרונות הקלסיים של קומפוזיציה של תמונה.

	
	ללא קוים מנחים (No guides) - לא מוצגים כל קוים.

	קווי אמצע (Centre lines) - מוצגים קווי אמצע בלבד

	חוק השלישים (Rule of thirds) - קווים מוצגים לפי חוק השלישים .

	חיתוך הזהב (Golden sections) - מוצגים קווים המציינים את חיתוך הזהב של המרובע.





כיווץ אוטומטי

כאשר כבר קיים אזור בחירה אקטיבי, אם תופעל אפשרות זו, אזור הבחירה יכווץ בצורה אוטומטית לגדלה של הצורה הריבועית הקרובה ביותר שבתוך אזור הבחירה. האלגוריתם המשמש כאן הוא "חכם", כלומר עשוי להניב תוצאות מצוינות או משונות באשר לבחירת הצורה המלבנית שלגדלה יכווץ אזור הפעיל.

מיזוג כיווץ

כאשר אפשרות זו פעילה, "כיווץ אוטומטי" יחפש את הצורה המרובעת אליה יכווץ איזור הבחירה הפעיל לא בשכבה הנוכחית אלא בכל החלקים הנראים של התמונה.



  
    GIMP/בחירת אליפסות


שימוש בסיסי
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הגדרות ברירת המחדל של כלי בחירת האליפסות.





[image: GIMP-Toolbox-SelectionEllipse-Icon.png] מקש קיצור: E

כלי בחירת האליפסות דומה מאוד לכלי בחירת המרובעים, בהבדל אחד: אין כאן אפקט פינות מעוגלות מאחר ואינו נחוץ. כפי שהשם מצביע, כלי זה מאפשר בחירת אזורים אליפטיים ומעגליים, עם אופציות החלקה באיכות גבוהה.

	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת האליפסה בכל לחיצה מחדש, או שכל אליפסה שתסומן תצורף לשטח שכבר מסומן וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.

	פריסה מהמרכז (Expand from center) - בחירת האליפסה תיעשה כאשר מיקום ההקלקה הראשונית הוא מרכז האליפסה.

	קיבוע (Fixed) - מאפשר לקבע מראש את צורת האליפסה: פרופורציות, גובה, רוחב או גודל אבסולוטי.

	מיקום (Position) - מיקום האליפסה.

	גודל (Size) - מאפשר לבחור את גודל האליפסה.

	הדגשה (Highlight) - מדגיש את האזור הנבחר ע"י הצללת האזור שמחוץ לבחירה.

	קווים מנחים (Guides) - מציג קווים מנחים שיופיעו בתוך האליפסה, קיימות 4 אפשרויות: ללא קווים, חלוקה לשלישים, חלוקת הזהב, קווי אמצע.

	כיווץ אוטומטי (Auto Shrink) - מכווץ את האליפסה הנבחרת לגדלו של האזור המרובע הקרוב ביותר בתמונה (ע"פ אלגוריתם בחירה "חכם").

	מיזוג כיווץ (Shrink merged) - אם אפשרות זו סומנה, הכיווץ האוטומטי ישתמש במידע מתוך צבע פיקסלים בתמונה כולה, ולא מהשכבה הפעילה בלבד.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקות למידע נוסף על החלקות.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.








לכל האפשרויות האחרות

ראה גם את כלי בחירת מרובעים שעבורו שאר אפשרויות ההגדרות זהות לחלוטין, או כמעט לחלוטין מלבד כאמור אפקט הפינות המעוגלות שאינו דרוש כאן.



  
    GIMP/בחירה חופשית


שימוש בסיסי
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הגדרות ברירת המחדל של כלי הבחירה החופשית.





[image: GIMP-Toolbox-SelectionLasso-Icon.png] מקש קיצור: F

כלי הבחירה החופשית (נקרא גם 'לאסו') מאפשר בחירת אזור ע"י ציור קו המתאר שלו ביד חופשית, או הנחת עוגנים שבניהם נמתח קו מתאר ישר. עם סגירת קו היקף על שטח, השטח יהפוך מיד לאזור בחירה פעיל. כלי זה הוא היחיד בין כלי הבחירה שאין לו אפשרויות הגדרה מלבד האפשרויות הבסיסיות.

כדי לסמן אזור בחירה, לחצו עכבר שמאלי והחזיקו לחוץ תוך ציור קו המתאר. אם תעזבו את הלחיצה לפני סגירת השטח, קו המתאר יישאר, אך הבחירה לא תתרחש עד סגירת השטח. במקרה זה בחירת האזור תתרחש עם הקלקה על העוגן הראשון (הנקודה שבה התחלתם את ציור קו המתאר). אפשרי לצייר היקף ע"י הקלקה ויצירה של עוגנים, או תוך לחיצה וציור, או שילוב לסירוגין של השניים.

	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת אזור בכל פעם מחדש, או שכל שטח שייסגר יצורף לשטח שכבר נבחר, וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקות למידע נוסף על החלקות.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.







  
    GIMP/בחירה ערפילית



שימוש בסיסי
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הגדרות בררת מחדל של כלי הבחירה הערפילית.





[image: GIMP-Toolbox-SelectionWand-Icon.png] מקש קיצור: U

בחירה ערפילית (נקראת גם 'מטה הקסם') הוא כלי לבחירת אזורים/שכבות בעלי צבעים עם גוון דומה זה לזה. לשימוש הקלק עם הכלי בנקודה כלשהי, והמטה יסמן כאזור בחירה פעיל את כל השטח שבקרבת נקודת ההקלקה שצבוע באותו צבע. בשימוש בכלי זה יש חשיבות לנקודת הבחירה הראשונית, אחרת תתקבל בחירה שונה לחלוטין מהבחירה שכוון אליה (לפחות בד"כ). המטה הוא כלי טוב לבחירת אובייקטים בעלי שוליים חדים. כמו כן זהו כלי מצוין לגימור אזורי בחירה, או בחירת אזורים בתוך קו מתאר כלשהו.

	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת שטח בכל לחיצה מחדש, או שכל שטח שיסומן יצורף לשטח שכבר מסומן וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.

	בחירת איזורי שקיפות - מאפשר בחירת אזורים שקופים.

	מיזוג דגימות - אפשרות חשובה מאוד עבור כלי זה, גורמת לכך שבחירת צבע תהיה מכל השכבות, ולא רק של השכבה הפעילה.

	צבע סף - קובע את רגישות הכלי לשינויי גוון.

	בחירה לפי - רכיב התמונה שישמש לחשב מה הוא האזור שייבחר ע"י כלי זה.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקה למידע נוסף על החלקה.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.





בחירת אזורים שקופים

כשאפשרות זו מסומנת, יכול כלי זה לבחור אזורים שקופים לחלוטין. כאשר אינה מסומנת, בחירת אזורים שקופים לא תתאפשר.

מיזוג דגימות

כאמור, אפשרות זו גורמת לכך שבחירת צבע תהיה מכל השכבות. כאשר יש בתמונה יותר משכבה אחת, והשכבה הפעילה היא או בעלת שקיפות מסוימת או מוגדרת במצב שכבה אחר מ"נורמלי", התוצאה יכולה להיות לא צפויה, כיוון שאם זה המצב, הצבעים המוצגים בשכבה יהיו שונים מאלו שייראו בתמונה עצמה.

סף צבע

סרגל זה קובע את רגישות הכלי לצבע, ולכן ישפיע על האזור שהכלי יבחר. ככל שנגרור את הסמן ימינה, יגדל מספר הגוונים של הצבע, שהכלי יכלול בבחירת השטח. אם נזיז את הסמן עד הצד הימני ביותר - כל הצבעים ייבחרו.

בחירה לפי

אפשרות זו מגדירה את רכיב התמונה בו ישתמש גימפ כדי לחשב מה הוא האזור שייבחר ע"י כלי זה. הרכיבים האפשריים הם : מורכב, אדום, ירוק, כחול, גוון, רוויה ו - ערך.



  
    GIMP/בחירה לפי צבע


שימוש בסיסי
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Selection by colour tool settings.





[image: GIMP-Toolbox-SelectionByColor-Icon.png] מקשי קיצור: Shift + O

כלי הבחירה לפי צבע מסמן את כל הפיקסלים בתמונה בעלי צבע מסוים. לבחירת צבע, הצביעו והקליקו עליו. כל האזורים בעלי הצבע הזה יסומנו כאזור בחירה פעיל, שניתן לבצע עליו את הפעולות הרגילות: העתקה, גזירה, הדבקה וכו'. ניתן לקבוע את דרגת הרגישות לגוון ע"י שימוש בשנתת "סף צבע" (Threshold) . כלי זה פועל בצורה דומה ל"בחירה ערפילית", בהבדל שבבחירה לפי צבע נבחרים כל הפיקסלים שבטווח הצבע הנבחר, ואילו בבחירה ערפילית נבחרים רק אזורים בצבע המתאים שגם נמצאים במיקום סמוך לנקודה שנבחרה.

	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת שטח בכל לחיצה מחדש, או שכל בחירה תצורף לשטח שכבר מסומן וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.

	בחירת איזורי שקיפות (Select transparent areas) - מאפשר בחירת אזורים שקופים.

	מיזוג דגימות - (Sample merged) אפשרות חשובה מאוד עבור כלי זה, גורמת לכך שבחירת הצבע היא מכל השכבות, ולא רק של השכבה הפעילה.

	צבע סף (Threshold) - דרגת הרגישות לגוון, כלומר טווח הצבע שייבחר.

	בחירה לפי - רכיב התמונה שישמש לחשב מה הוא האזור שייבחר ע"י כלי זה.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקה למידע נוסף על החלקה.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.








לכל האפשרויות האחרות

ראה גם בחירה ערפילית שעבורו שאר אפשרויות ההגדרות זהות לחלוטין, או כמעט לחלוטין.



  
    GIMP/מספריים



[image: ]



הגדרות ברירת המחדל של מספריים.





שימוש בסיסי

[image: GIMP-Toolbox-SelectionScissors-Icon.png] מקש קיצור: I

מספריים הוא כלי בחירה מעניין. יש לו כמה מאפיינים משותפים עם כלי הבחירה החופשית (Free Selection/Lasso) , עם כלי סימון הנתיבים (Path tool), וכמה מאפיינים ייחודיים לו. כלי זה שימושי לבחירת אזורים המוגדרים ע"י שינויי צבע חדים בקצותיהם.

להתחלת סימון אזור, הקליקו בעכבר שמאלי על נקודה בהיקף הרצוי. הקליק יוצר עוגן. הקליקו וצרו עוגן נוסף בנקודה נוספת סמוכה לראשונה, שגם היא על היקף הצורה שאותה אתם מסמנים. בין שני העוגנים האלו יופיע קו, שינוע לאורך המקומות בין שני העוגנים, שבהם מתרחשים שינויי הצבע הגדולים ביותר (תוך שמירה על כוון כללי).

לשם הפיכת השטח לאזור בחירה פעיל סוגרים את השטח ע"י הקלקה על העוגן הראשון, ואז הקלקה נוספת על נק' כללית בתוך ההיקף שיצרנו, או לחיצה על Enter.

עד סימון השטח כאזור בחירה פעיל ניתן לשנות ולשפר את האזור שנוצר ע"י הזזת העוגנים. כדי להזיז עוגן לחצו עכבר שמאלי, גררו אותו למקום הרצוי, ושחררו את הלחיצה. ניתן גם להוסיף עוגנים בכל שלב עד שהשטח כבר אזור בחירה פעיל.

יש לזכור: שלבי הסימון בכלי זה אינם נכללים כפעולות ב"היסטוריה" ולכן ברגע שנחליף כלי, העוגנים שבחרנו ייעלמו. כלומר אם השקענו הרבה בסימון שטח אבל לא לחצנו "Enter", החלפת כלי תגרום לכך שהשטח שסימנו ייעלם ונצטרך להניח את כל העוגנים מחדש.

	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת שטח בכל לחיצה מחדש, או שכל שטח שיסומן יצורף לשטח שכבר מסומן וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.

	גבול אינטראקטיבי - הקימורים יוצגו אוטומטית בזמן בחירת הצומת.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקה למידע נוסף על החלקה.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.





גבול אינטראקטיבי

כאשר אפשרות זו פעילה, בין שני עוגנים יועברו עקומות לאורך אזור שינוי הצבע, עוד לפני הנחת העוגן המוזז במקומו. כאשר אפשרות זו אינה פעילה, בעת יצירת או הזזת עוגן, יוצג בינו לבין העוגנים הסמוכים קו ישר, עד שיונח במקום. על מערכות אטיות יש יתרון לכך שזו אינה ברירת המחדל.



  
    GIMP/בחירת קידמת תמונה



[image: ]



הגדרות ברירת המחדל של כלי בחירת קדמת תמונה.






שימוש בסיסי

[image: GIMP-Toolbox-SelectionForeground-Icon.png] מקש קיצור: אין

כלי זה משמש לבחירת אובייקטים כגון דמויות, עצמים, אזור בעל מאפיינים ברורים בנוף, או מה שנכנה במדריך זה "אזור קידמת תמונה". הכלי מבצע את בחירת האובייקט מתוך השכבה הפעילה, תוך שימוש בשיטת SIOX. לתהליך 3 שלבים:

	כאשר מפעילים את הכלי הוא במצב הנחת עוגנים. נניח עוגנים על היקף האובייקט שלנו. נשתדל לכלול כמה שפחות אזור "רקע" בשטח המסומן. שלב זה מסתיים כשסוגרים את השטח ע"י הקלקה על העוגן הראשון. עם סגירת השטח, האזור שאינו כלול בו יואפל.

	עתה, הכלי הופך לדוגם צבע. יש ללחוץ עכבר שמאלי ו"לצייר" קו שעובר על כל סוגי הצבעוניות שהאובייקט שלנו מכיל. כאשר נשחרר את הלחיצה, כאשר נשחרר את הלחיצה מסימון הקו הזה, גימפ יעדן את בחירת קידמת התמונה לפי הצבעים שעברנו דרכם. אפשר לחזור על שלב זה לעידון התוצאה.

	כאשר האזור המסומן משביע רצון, יש ללחוץ Enter, והאזור שאינו מוצלל יהפוך לאזור בחירה פעיל.



יש לזכור שלבי הסימון בכלי זה אינם נכללים כפעולות ב"היסטוריה" ולכן ברגע שנחליף כלי העבודה תיעלם אם לא לחצנו Enter.


	
	מצבי בחירה (Modes) - קובע את הדרך בה ייבחר השטח: האם בחירת אזור בכל לחיצה מחדש, או שכל אזור שיסומן יצורף לשטח שכבר מסומן וכו'.

	החלקה (Antialiasing) - גורם לבחירת אזור עם קצוות או גבולות חלקים יותר.

	קצוות נוצה (Feather edge) - גורם לבחירת אזור עם קצוות מטושטשים בצורה עדינה, עם אפשרות לבחור רדיוס טשטוש.

	אזור רציף (Contiguous) - כאשר אפשרות זו פעילה, ייבחרו רק שטחים הגובלים ("נוגעים") באזור הבחירה.

	עידון בחירה אינטראקטיבי - הגדרות עבור המברשת.

	חלקות - קובע את חלקותו של אזור הבחירה.

	בחירת צבע כיסוי(Preview color) - כאן ניתן לשנות את צבע הצללת הרקע של אזור הבחירה.

	רגישות לצבע - הגדר את הגיון בחירת האזור, לפי רגישות לגוני צבע.





מצבים, החלקות וקצוות נוצה

	
	ראה כלי בחירה#מצבים למידע נוסף על מצבי בחירה.

	ראה כלי בחירה#החלקות למידע נוסף על החלקות.

	ראה כלי בחירה#קצוות נוצה למידע נוסף על קצוות נוצה.





אזור רציף (Contiguous)

כאשר אפשרות זו מסומנת, ייבחרו רק אזורים עם גבול משותף למשיכת המכחול. כאשר אפשרות זו אינה מופעלת, כל אזור בעל צבע דומה בתמונה ייבחר.

עידון בחירה אינטראקטיבי

האפשרויות הבאות נוגעות לשימוש בכלי או סוג המברשת שנבחרו לסימון השטח לבחירה.

סימון רקע/קידמת תמונה

מחליף בין סימון קידמת תמונה לסימון רקע. המקש Ctrl משמש למעבר בין המצבים הללו. יש לזכור! אזור שיסומן כרקע יימחק.

חלקות

שנתה זו מאפשרת לסגור חורים באזור הבחירה. יש לזכור - ערכים קטנים יותר יגרמו לגבול חד יותר אך עשויים ליצור חורים באזור שייבחר.

בחירת צבע כיסוי

מאפשר לבחור את הצבע שישמש להצללת אזור הרקע בעת סימון השטח. האפשרויות הן כחול, אדום וירוק, כחול הוא ברירת המחדל.

רגישות לצבע

אפשרות זו משתמשת במודל הצבע L A B. אם התמונה מכילה פיקסלים רבים מאותו צבע בגוונים שונים, כאן ניתן להגיע לבחירה מוצלחת יותר עבור הצבע הזה.

שנתת גודל מברשת

שנתה שמאפשרת שינוי גודל המברשת. מברשת קטנה טובה לפרטים עדינים, מברשת גדולה טובה לבחירת רקע כללית.



  
    GIMP/דוגם הצבע


שימוש בסיסי


[image: ]



הגדרות ברירת המחדל של דוגם הצבע.





[image: GIMP-Toolbox-ColourPickerTool-Icon.png] מקש קיצור: O

הקלקה עם כלי זה על צבע מסוים תשנה את צבע המברשת הנוכחית לצבע עליו הקלקנו. בצד שמאל תוכלו לראות תמונה של הגדרות בכלי זה. הנה תיאור קצר של כל מה שנמצא שם:

	
	דגימה ממוצעת - גורם לכך שהדגימה תהיה של ממוצע הצבעים המופיעים בשטח ברדיוס מסוים (1ניתן לשינוי מ עד 300px) מסביב לנקודה עליה הקלקנו.

	דגימת מיזוג (Sample merged) - מגדיר אם לדגום את צבע השכבה הנוכחית בלבד, או לדגום את הצבע הנראה, גם אם הוא מורכב מצבעים ושקיפויות של שכבות מרובות.

	מצב בחירה (Pick mode) - ראה "מצבים" למטה.

	הצג חלון מידע (Use info window) - מגדיר אם להציג חלון מידע על הצבע, ראה למטה.





מצב בחירה


[image: ]



חלון המידע.





לדוגם הצבע 4 מצבים, הנה תיאור שלהם:

	
	בחירה בלבד (Pick only) - בוחר צבע בלבד, בלי לעשות שום שינוי או עיבוד לצבע הנדגם; חלון המידע חייב להיות מופעל.

	הגדר צבע קדמי (Set foreground colour) -הצבע שנדגם ישמש כצבע קדמי, נקרא גם "הצבע הפעיל", זהו הצבע שישמש בעת שימוש בכלי ציור כמו מברשת/דלי הצבע וכו';

	הגדר צבע רקע - הצבע שייבחר ישמש כצבע רקע, שנקרא לעתים "צבע אחורי". לצבע זה משמעות בפעולות מסוימות, למשל זהו הצבע שימלא את האזורים בעת שימוש במחק;

	הוסף ללוח הצבעים - כשמו כן הוא. שימושי מאוד כאשר אנו רוצים ליצור לוח צבעים מותאם לתמונה שאנו הולכים לצייר למשל;





מקש Ctrl מעביר בין "הגדר צבע קדמי" ל"הגדר צבע רקע" כאשר אחד המצבים האלה פעיל.

הצג חלון מידע

חלון המידע מציג 2שתי עמודות מידע על הצבע הנדגם. ניתן להגדיר את סוג המידע שיוצג בכל עמודה, כאשר האפשרויות בשתיהן הן pixel, RGB, HSV and CMYK . כברירת המחדל מוצגים pixel ו- RGB. ניתן להציג את חלון המידע גם בדרך נוספת, ע"י החזקת מקש Shift לחוץ בעת דגימת הצבע.



  
    GIMP/זום
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תפריט כלי ההגדלה (זום).





[image: GIMP-Toolbox-MagnifyTool-Icon.png] מקש קיצור: Z

כלי הזום משמש להגדלת אזורים נבחרים של התמונה. כברירת מחדל, כאשר בוחרים את הכלי ומסמנים אזור, האזור הנבחר יוגדל לגודל חלון התמונה. אם לא יסומן שטח, הקלקה על כל מקום בתמונה תגדיל או תקטין את כל התמונה, לפי הפעולה שמוגדרת. ניתן להפך בין הגדלה להקטנה באופן זמני ע"י החזקת מקש Ctrl לחוץ בזמן הפעולה.

באזור ההגדרות של הכלי קיימת אופציה Auto-resize window, שאינה מופעלת כברירת מחדל. הפעלת אופציה זו תגרום לכך שפעולת הזום תשפיע גם על גודל החלון.

מקשי התאמה

Ctrl - שינוי כוון הזום כלומר הגדלה או הקטנה של התמונה.

Ctrl + גלגל העכבר - החזקת מקש Ctrl תוך גלגול הגלגלת קדימה ואחורה תשנה את רמת הזום של התמונה, גם כאשר אנו עובדים עם כלי אחר.

שליטה בזום מתחתית חלון התמונה

בסרגל הכי תחתון של חלון התמונה, מתחת לתמונה עצמה בצד שמאל, קיים אזור אינדיקציה, שבו יש בין היתר אפשרות לקבוע ישירות את דרגת הזום באחוזים מגודל התמונה האבסולוטי. בנוסף, קיימת אופציה חשובה ליד דרגת הזום, והיא הגדרת שנתת הגודל של התמונה. אפשרות ברירת המחדל עבור אמת המידה כאן היא פיקסלים, אך יש אפשרות לשנותה למילימטרים, אינטשים, רגליים (feet) וכן אמות מידה מקצועיות כגון פיקה,



  
    GIMP/מדידה
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תפריט כלי המדידה.





[image: GIMP-Toolbox-MeasureTool-Icon.png] מקשי קיצור: Shift + M

כלי זה מאפשר מדידה של מרחקים וזוויות בין נקודות, ואורך ורוחב של שטח המרובע שהן מגדירות. המידע מוצג בשורת המצב בתחתית חלון התמונה, וכן יש אפשרות להציג אותן בחלון מידע ע"י בחירת Use info window בהגדרות הכלי. התנהגות כלי זה בגרסאות שונות של גימפ שונה במקצת מהמתואר כאן, אך התפקוד הבסיסי זהה.

מקשי התאמה

Shift - מתחיל מדידה חדשה מנקודת הסוף של הנקודה הקודמת, תוך שמירה על המידע של המדידה הקודמת. שימושי למדידת תוואי בתמונה.

Ctrl - שם את הכלי במצב קווים ישרים, גורם למד הזווית לדלג בצורה בדידה (דיסקרטית) בקפיצות של 15 מעלות בין נקודה לנקודה.

Alt - יוצר קו מנחה אופקי כאשר מחזיקים אותו לחוץ ומקליקים.

Ctrl + Alt - לאחר מדידה, כאשר לוחצים מקשים אלה יחד הם מאפשרים הזזה ע"י גרירה של הקו שמסמן את המדידה. כאשר הם לחוצים יחד ומקליקים על אחת מנקודות הקצה של קו המדידה, הם מוסיפים קוים מנחים אופקי ואנכי בנקודת הקצה.
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שימוש בסיסי


[image: ]



הגדרות ברירת המחדל של כלי הוספת מלל.





[image: GIMP-Toolbox-TextTool-Icon.png] מקש קיצור: T

כלי זה מאפשר הכנסת מלל לתמונה או ציור. כאשר מפעילים את הכלי, הסמן נראה כמו סמן הכלי לבחירת מרובעים. סמנו בעזרתו את המרובע שבו תרצו להכניס מלל. הסימון יביא לפתיחת חלונית קטנה נפרדת (ראו עורך המלל ), בה תוכלו להזין את המלל, ואף לייבא טקסט מקובץ כפי שמוסבר בהמשך. הוסיפו מלל ולחצו על "Close". בדקו שהמרובע ממוקם כרצונכם, והתאימו אותו אם לא. כל הזנת מלל בגימפ מביא ליצירה של שכבת מלל. שכבה זו היא שכבה עם רקע שקוף, בגודל המרובע שהגדרנו. את המרובע הזה ניתן בקלות לשנות ולהזיז בכל שלב בהמשך, פשוט ע"י בחירת כלי המלל והפעלת שכבת המלל שנרצה לשנות.

המלל בכל שכבה הוא אחיד: באותו צבע, באותו גופן, גודל אות וכו'. אם נרצה לשנות צבע למשל, נצטרך להוסיף שכבת מלל נוספת.

בתמונה בצד שמאל מוצג מצב הגדרות ברירת המחדל של הכלי. הרשימה הבאה מספקת תיאור קצר של כל מה שקיים שם, ובהמשך יש פירוט.

	
	גופן (Font) - בחירת גופן.

	גודל (Size) - גודל הגופן לפי גובה.

	גופן מרומז (Hinting) - מתאים את תוואי האות כדי לשפר את הקריאות של המלל כאשר האותיות קטנות.

	אוטומציית גופן מרומז (Auto-hinter) - מנסה לחשב אוטומטית מידע גרפי של תוואי הגופן וצבעוניות הסביבה כדי לאפשר יתר קריאות באותיות קטנות.

	החלקה (Antialiasing) - מספק החלקה של תוואי הגופן.

	צבע גופן - בחירת צבע הגופן.

	יישור (Justify) - מגדיר לאיזה כוון לישר את המלל.

	הזחה (Indent) - מזיז את נקודת התחלת המלל משולי המרובע, במרחק קצוב כל לחיצה.

	ריווח שורות (Line spacing) - מגדיר את גודל הרווח בין שורות המלל.

	ריווח אותיות (Character spacing) - מגדיר את הרווח בין האותיות.

	טקסט לאורך נתיב (Text along Path) - פורש את המלל לאורך הנתיב הפעיל בתמונה, אם קיים.

	נתיב לפי טקסט (Path from Text) - יוצר נתיב בחירה מקו המתאר של המלל המסומן.





גופן

בגימפ יש דרך יחידה לבחור את הגופן, והיא כאן.

הוספת גופנים

ניתן להוסיף פונטים לגימפ, בד"כ ע"י הוספת הקבצים של הגופן המבוקש לספריית הגופנים של גימפ, ואז לחיצה על רענון תפריט הגופן, או הפעלה מחדש של גימפ.

שינוי תצוגת פונטים

כדי לשנות את הדרך בה תפריט בחירת הגופן נראה, יש ללחוץ על צלמית בחירת הפונט. בתחתית תפריט הגלילה שנפתח קיימות כמה אפשרויות: החלפה בין תצוגה של רשימה שמית עם דוגמה לכל גופן, לתצוגה של טבלה של תווים בלבד, שמאפשרת בחירה מהירה של גופן לפי צורתו. כמו כן ניתן להגדיל ולהקטין את התצוגה המקדימה של הגופנים.

גודל

שינוי גודל אות. ניתן לעשות זאת בשתי צורות: להקליד את הערך המספרי או לשנות גודל בעזרת החיצים שבצד. כמו כן אפשר לשנות את יחידת המידה של הגודל. ברירת המחדל היא פיקסלים, וגופן בגודל 18.

החלקה

מעבד את הטקסט להצגה בתהליך שמייצר תוצאות עם צורה חלקה יותר ופחות פיקסול. :ראה | Antialiasing למידע נוסף

צבע גופן

שינוי צבע הגופן. שינוי ההגדרה כאן לא ישנה את צבע המלל שכבר הוקלד. יש לבחור מחדש את המלל, לשנות את הצבע וללחוץ "OK".

יישור

יישור המלל לפי האפשרויות הבאות:

	
	Left justified - יישור לשמאל

	Right justified - יישור לימין

	Centered - יישור למרכז

	Filled מילוי כל רוחב השורה ע"י ריווח אותיות אוטומטי.





הזחה

שולט במרחק המלל משולי אזור הצגת הכתב. ברירת המחדל היא 0.0 פיקסלים.

ריווח שורות

גודל הרווח בין השורות. ברירת המחדל מוצגת כ 0 אך המרחק הממשי אינו 0 והוא משתנה לפי פרמטרים של הגופן שבשימוש. ערכים שליליים אפשריים.

ריווח אותיות

ריווח בין תווי הכתב. מתנהג כמו ריווח בין שורות, וגם כאן ערכים שליליים אפשריים.

מלל לאורך נתיב

כדי להפעיל אפשרות זו יש ליצור קודם נתיב. אם קיימים מספר נתיבים בתמונה יש לבחור את הרצוי מבניהם בדיאלוג הנתיבים. כאשר הנתיב הרצוי פעיל, לחיצה על "Text along Path" תפרוש את המלל לאורך הנתיב, ותהפוך את קווי המתאר של האותיות לנתיב בפני עצמו.

נתיב לפי טקסט

פונקציה שימושית מאוד ליצירת כתב מיוחד בתמונה. בחירת "Path from Text" גורמת ליצירת נתיב לאורך קווי המתאר של האותיות, וניתן לשנות את צורת האותיות ע"י שינוי מיקום העוגנים של נתיב זה, והוספת חדשים.

עורך המלל


[image: ]



חלון עריכת המלל.





דיאלוג זה נפתח כאשר מסמנים אזור להזנת מלל. המלל שיוזן כאן יופיע ישירות בתמונה, בתור שכבת מלל נפרדת. אם האפשרות "Show Layer Boundary" (הצג גבולות שכבה) מסומנת בהגדרות שבתפריט "View" בראש חלון התמונה, גבולות שכבת המלל יודגשו במתאר שחור-צהוב. אפשר להזיז את מיקום שכבת המלל בעזרת כלי ההזזה אם מקליקים ישירות על המלל, או בעזרת כלי המלל עצמו, כאשר השכבה הזו פעילה. ברגע שמתחילים לכתוב, מופיעה שכבת מלל בדיאלוג השכבות. ניתן לערוך את הטקסט מחדש אחרי החלפת כלי ע"י בחירתו מחדש והפעלת השכבה הרצויה, והקלקה על אזור המלל. לאחר שמירת הקובץ ניתן לערוך את הטקסט רק אם הקובץ נשמר בפורמט הטבעי של גימפ - .xcf . להוספת תיבות מלל נוספות - יש להקליק על אזור שאינו שכבת מלל, וייפתח דיאלוג עריכת מלל חדש. דיאלוג עריכת המלל עצמו מציג את עורך המלל של גימפ, שבו ניתן מלבד הקלדה, לבצע את הפעולות הבאות:




	
	פתיחת קובץ (Open) - טוען מלל מקובץ.

	ניקוי (Clear) - מוחק את כל המלל בשכבה זו.

	LTR - מיישר את המלל הנבחר משמאל לימין.

	RTL - מיישר את המלל הנבחר מימין לשמאל.

	השתמש בפונט שנבחר (Use selected font) - מאפשר לקבוע אם מלל מקובץ יוצג בגופן שמסומן בגימפ.





פתיחת קובץ

ניתן להוסיף מלל מקבצים בפורמטים מסויימים, ע"י לחיצה על סמל התיקייה בחלון עורך המלל, ובחירת הקובץ. ניתן לפתוח מספר קבצים לאותו חלון מלל. כל פעולה כזו ניתנת לצפייה בחלון היסטוריית הפעולות וניתן לחזור אחורה ולבטלה.

נקה

לחיצה על הכפתור עם ציור המטאטא ימחק את כל המלל בחלון זה. כל פעולה כזו ניתנת לצפייה בחלון היסטוריית הפעולות וניתן לחזור אחורה ולבטלה.

LTR ו RTL

LTR - המלל יוצג משמאל לימין, כמו ברוב השפות המערביות RTL - המלל יוצג מימין לשמאל, כמו שכותבים בעברית, ערבית וכמה שפות מזרחיות נוספות.

השתמש בגופן שנבחר

כברירת מחדל כאשר פותחים מלל מקובץ, הגופן של הקובץ נבחר באופן אוטומטי. בחירת אפשרות זו תשאיר את הגופן כפי שנבחר בגימפ.



  
    GIMP/הוספת גופנים


מידע כללי

גימפ מגרסה 2.X יודע להשתמש במגוון פורמטים של גופנים, בין היתר TrueType, OpenType ו - Type1. הדרך בה גימפ 2.X מגיש גופנים השתנתה מאוד מהגרסאות הקודמות. מגימפ 2.X והלאה לא נעשה שימוש בשרת X, אלא בספריות Pango ו - FreeType . דבר זה איפשר תמיכה טובה יותר משמעותית בשימושים של דו-כווניות של מלל (עברית/איגלית) , החלקת קצוות (Antialiasing), ושימוש בתסריטים.

הוספת גופנים

ניתן להוסיף גופנים לגימפ, בד"כ ע"י הוספת הקבצים של הגופן המבוקש לספריית הגופנים של גימפ, ואז לחיצה על רענון תפריט הגופנים, או הפעלה מחדש של גימפ. כדי למצוא מה היא ספריית הגופנים הנוכחית עבור המשתמש הספציפי שכרגע עובד עם גימפ, גשו בתפריט הראשי אל: Edit -> Preferences -> Folders -> Fonts . משמצאתם את הספרייה הדרושה, העתיקו את ספריית הגופנים לשם, ורעננו או הפעילו מחדש את גימפ. אם הגופן נוכח בספריית הגופנים של מערכת ההפעלה, כנראה שהוא נגיש לגימפ באופן ברירת מחדל.

גופנים חינמיים בעברית

מלאי הפונטים החינמיים בעברית גדל מעט בשנים האחרונות, אך עדיין הנושא דורש תשומת לב. מומלץ להיזהר משימוש בפונט שלא בהתאם לרישיון שבו הוא מוגש, כדי להימנע מתביעות בלתי צפויות. לכן תמיד שימו לב שאינכם עושים שימוש בפונט שדורש רישיון בתשלום, אלא אם רכשתם רישיון מתאים.

קיימות מספר חבילות פונטים חינמיים באיכות טובה, והקוראים מוזמנים להוסיף לרשימה הבאה:

	http://freefonts.co.il/ חלק מהפונטים ברישיון GNU-GPL , וחלק לא, בדקו את הרישיון עבור כל פונט בנפרד.
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פעולות על תמונה

פעולות על קובץ התמונה, וכן פעולות עריכה רבות אינן מוצעות בארגז הכלים. ניתן להגיע אליהן מהתפריט הראשי של גימפ, שנפתח ע"י קליק ימני על התמונה. מגרסה 2.0 של גימפ תפריט זה מוצג גם בראש חלון התמונה, אך ניתן להסתירו כדי להגדיל את השטח המשמש לעריכת התמונה.

בתפריט הראשי קיימות 10 כניסות, דף זה יעסוק לשם מיקוד הנושא ב 2 מהן : "File" ו - "Image". נביא דוגמה לחלק מהאפשרויות המצויות בכל אחד מהתפריטים, ונשאיר את הקורא הנבון להבין לבד איך למצוא ולהפעיל שימושים נוספים, או לחפש מידע בהמשך המדריך, בדפים מפורטים יותר.

שמירת תמונה בפורמטים שונים

בכניסה "File", לפי הסטנדרט של תכנות שולחן עבודה, ניתן לשמור את הקובץ עליו אנו עובדים ברגע זה, לפתוח קבצים נוספים, להדפיס תמונה ולצאת מגימפ. כמו כן יש אופציות שימושיות כגון שמירת עותק של התמונה בשם אחר. אנו נתאר כאן תהליך של שמירת תמונה בשם ובפורמט הרצויים:

עבור אל "File > Save as" ובחלון שייפתח בחר את הספרייה בה תרצה לשמור את הקובץ, את שם הקובץ ואת הפורמט. תהליך שמירת התמונה בגימפ מציע אפשרויות אינטראקטיביות רבות באשר לפורמט ולאיכות. למשל:

הפורמטים המומלצים לשם הוספת תמונה לויקיפדיה הם JPG ו - PNG. נניח שאנו רוצים לשמור את התמונה שאנו עובדים עליה לשימוש זה. נלחץ קליק ימני, ובתפריט שנפתח נבחר "File > Save as". נוכל גם להשפיע על גודל קובץ התמונה ע"י התאמת איכות התמונה. שינוי האיכות ניתן להשגה ע"י שימוש בשנתה Quality, כאשר ככל שנעלה את איכות התמונה גודל הקובץ שיתקבל יגדל. לשמחתנו, לא תמיד יש צורך בתמונה באיכות גבוהה מאוד. כדי לבדוק אם התמונה המתקבלת מתאימה לנו, נוכל לסמן את האפשרות Show preview in Image Window וכך נדע איך ייראה הקובץ שיתקבל.

הצגת מידע על התמונה הנוכחית
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תיבת מאפייני תמונה.





בכניסה "Image" קיימות אפשרויות שימושיות ביותר כמו הגדלת והקטנת תמונה לגודל הרצוי (Scale) שינוי גודל משטח הציור (Canvas) בלי לשנות את גודל התמונה עצמו, שיכפול התמונה, קיצוץ שוליים אוטומטי, מיזוג השכבות הנראות (Visible) בתמונה ועוד. למשל, לעתים שימושי ביותר לקבל מידע על מאפייני התמונה. ניתן לקבל מידע זה ע"י Image > Image Properties , או לחיצה על מקשי הקיצור Alt-Enter. שלושת הנתונים הראשונים בחלון שנפתח (ראו משמאל) חשובים מאוד עבור תמונות המיועדות לדפוס: Pixel Dimensions, Print Size, ו - Resolution.

שינויי גודל התמונה

שימו לב שבשני המקרים הבאים ניתן לשנות את יחידת המידה מפיקסלים למילימטרים, אינטשים וכו', וכן ניתן לשנות את הרזולוציה לערך המבוקש.

Image > Canvas size בתפריט שבראש העמוד. שימו לב שבחלון שנפתח ניתן למקם את התמונה בתוך המשטח בגדלו החדש, למשל למרכז את התמונה או להצמידה לימין.

Image > Scale image בתפריט בראש העמוד. שימושי למשל בשביל יצירת בגודל מסויים.

מחיקת חלקים מהתמונה

מחיקת מקטע תגרום לחלק שנמחק "לחזור" לצבע שמוגדר כצבע הרקע, או להפוך שקוף, תלוי בפורמט התמונה ובהגדרות הנוכחיות של השטח שנמחק. המחיקה מתבצעת על השכבה הפעילה, ולאו דווקא על השכבה העליונה. למחיקת מקטע, סמנו את החלק שברצונכם למחוק בעזרת אחד מכלי הבחירה (בחירת מרובעים או אליפסות, מספריים וכו') ואז ביכולתכם למחוק באחת הדרכים הבאות:

	מקש Delete

	מקשים Control-K

	מהתפריט הראשי - בחרו Edit > Clear




  
    GIMP/צבעים


גימפ מבין מספר מודלים לייצוג צבע בדרגת תמיכה ואיכות משתנות. קיימת תמיכה במצבי הצבעוניות הבאים: RGB, grayscale ו- indexed . לשינוי מצב צביעה יש לגשת לתפריט בראש חלון התמונה ולבחור: Image > Mode





מצבי צבעוניות

מצבי הצבע הנתמכים:




	"צבע אמיתי" (True Colour (RGB: למצב זה התמיכה הטובה ביותר בגימפ. הוא מורכב מ 3 ערוצי צבע בעלי 256 וריאציות גוון בכל אחד מהם, שמסתכמים לכדי 16.7 מיליון צבעים - 256 * 256 * 256.
פורמטים של מצב צביעה זה שגימפ תומך בהם: XCF, PNG, TGA, TIFF, SGI, BMP.



	סולם אפור Grayscale: גימפ תומך היטב בפורמט זה, שמשתמש בערוץ אחד בלבד להצגת תמונה בשחור-לבן. רוב הכלים של גימפ עובדים היטב ומספקים את התוצאה הצפויה, להוציא כלים שדורשים קיום של נתוני צבע
פורמטים נתמכים: XCF, PNG, TGA, TIFF, SGI.



	פלטה מותאמת Indexed: במצב צביעה זה התמונה מורכבת מפלטת צבעים מותאמת המכילה 256 צבעים. מטרת מצב זה היא לרוב הקטנת גודל קובץ התמונה, או במקרים מסוימים חיסכון בכוח מחשוב בעריכתה. כאשר מעבירים תמונה למצב צביעה זה, או כאשר מפחיתים "עומק צבע" ("color depth") של תמונה, האופציה "עידון השתנות צבע" מאפשרת לקבוע כיצד הצבעים יפוזרו. לתוצאות האיכותיות ביותר עבור תמונות עם שינויי גוון הדרגתיים מומלץ לבחור "Floyd-Steinberg dithering". אופציה זו תוסיף גרעיניות לתמונה, אבל תפחית אפקט של ריצוע צבע. מצד שני עידון השתנות צבע (dithering) יגדיל במקצת את גודל הקובץ לכן אם זו המטרה מומלץ להשתמש באפשרות זו בערכים נמוכים או לא להשתמש בה בכלל בעת שמירה בפורמטים GIF, PNG או BPM עם האפשרות "Run-Length Encoded" מופעלת.
פורמטים נתמכים: XCF, PNG, GIF, BMP.



	מונוכרום Monochrome: שני צבעים, לעתים קרובות שחור-לבן, גימפ רואה אפשרות צביעה זו כתמונה עם פלטה מותאמת בעלת 2 צבעים בלבד.
פורמטים נתמכים: XCF, PNG, GIF, BMP.




בתפריט הצבע בראש החלון קיימות הכניסות הבאות:

	Image > Mode > RGB

	Image > Mode > Grayscale

	Image > Mode > Indexed


ערוץ אלפא

ללא קשר למצב הצביעה, הוספת ערוץ אלפא מאפשר לתמונה אזורים בעלי שקיפות בדרגה משתנה. כל פיקסל בתמונה מקבל ערך שקיפות בין 0 ל 255. שימוש בתמונה בעלת ערוץ אלפא מאפשר ליצור תמונות עם חורים או אזורי שקיפות חלקית עבור שימושי WEB, או גרפיקה תלת ממדית.

פורמטים שתומכים בערוץ אלפא באופן מלא: XCF, PNG, TIFF, TGA, SGI. פורמטים שתומכים בערוץ אלפא רק עבור ערכים של שקיפות מלאה וצבע אטום (כלומר חסר שקיפות): GIF, XPM.

הערה לגבי דפדפנים: אחת התכונות הידועות של דפדפנים היא שקיימת תמיכה בשקיפות תמונות בדפדפנים נפוצים רק החל מאינטרנט אקספלורר 7.

בתפריט ערוץ אלפא בראש החלון קיימות הכניסות הבאות:

	Layer > Transparency > Add Alpha Channel

	Layer > Transparency > Remove Alpha Channel

	Layer > Transparency > Add to Selection


פילטרים/כלי צבע

בתפריט הראשי שבחלון התמונה תחת Image אפשר למצוא מספר פונקציות עיבוד תמונה נוספות:

	Image > Mode > Decompose יפרק את התמונה לסדרה של תמונות בסולם אפור, בהתאמה לאחד מכמה מודלים של צביעה.

	Image > Mode > Compose מבצע את הפעולה ההפוכה ומרכיב סדרה כזו לתמונה צבעונית. ניתן להגיע לאפקטים מדהימים בשיטה זו, ע"י הרכבה מחדש של הסדרה ע"פ מודל שונה מזה ששימש לפירוק התמונה המקורית.

	Image > Colours מספק מספר אפשרויות להתאמות צבע.

	Image > Filters > Colours גם כאן קיימים כמה אפקטים של צביעה.


מקורות

	Mode in GIMP manual




  
    GIMP/שמירה


כדי לשמור תמונה יש ללחוץ עכבר ימני על התמונה ולבחור File > Save. בגרסאות החדשות של גימפ תפריטים אלו נגישים גם מראש חלון התמונה. בעת שמירת התמונה ניתן לבחור את הפורמט הרצוי מתפריט, אך באופן ברירת מחדל פורמט הקובץ ייקבע ע"י סיומת שם הקובץ (לדוגמה, שמירת התמונה בשם image.jpg יגרום לשמירת הקובץ בפורמט JPG ). פורמטים נפוצים: JPG ו - PNG

לאחר בחירת הפורמט הרצוי עשוי להיפתח דיאלוג נוסף עם אפשרויות שמירה ספציפיות לעבור הפורמט שבחרנו. למשל עבור תמונת JPG ייפתח חלון שדרכו אפשר לקבוע את דרגת דחיסת המידע. זה שימושי שגימפ מאפשר לנו לשנות נתון זה, שכן דחיסה גבוהה גורמת לעתים לאיבוד איכות מסוים אך מייצרת קובץ קטן יותר. דוגמה נוספת היא שבעת שמירת תמונה שמכילה מס' שכבות בפורמט שאינו משמר את תכונת השכבות, כגון JPG ו PNG, ייפתח חלון שיאפשר לבחור כיצד יש למזג את השכבות.


פורמטים של תמונה הנתמכים ע"י גימפ

גרסת גימפ 2.2.13 וגרסאות מאוחרות יותר

Significant file formats
	פורמט הקובץ
	סיומת
	תיאור

	XCF
	.xcf/

.xcf.gz/.gz/.xcfgz/ .xcf.bz2/.bz2/.xcfbz2/ .gbr/.gih/.pat
	הפורמט הטבעי (Native) של גימפ. שמירה בפורמט זה יישמר את כל המידע של התמונה כולל שכבות, אזור הבחירה הפעיל, ערוצים, הגדרות שקיפות שונות, נתיבים וקווי רשת וקווים מנחים, אך לא יישמר את היסטוריית הפעולות של עריכת התמונה. קבצי XCF תופסים הרבה מקום, וכן אינם נתמכים ע"י תוכנות הצגת תמונה הנפוצות, כלומר פורמט זה מיועד לשמירת התמונה עבור המשך עריכה בגימפ. תכנות עריכה פופולריות כגון פוטושופ אינן תומכות בפורמט זה. קיימת אפשרות לשמור את התמונה בפורמט XCF מכווץ, ע"י כיווץ GZIP (סיומות xcf.gz/gz/xcfgz ) או BZIP (סיומות xcf.bz2/bz2/xcfbz2 ) . פורמטים טבעיים נוספים לגימפ כוללים את (GIMP Brush (.gbr), GIMP Animated Brush (.gih), ו - (GIMP Pattern (.pat .

	BMP
	.bmp/.dib
	Bitmap הוא פורמט בלתי מכווץ, והוא הפורמט הטבעי של מערכות הגרפיקה של WINDOWS השונות וכן של OS/2.

	GIF
	.gif
	Graphic Interchange Format משמש לעתים קרובות לצילומי מסך וגרפיקת מחשבים. זהו פורמט משמר (lossless) במקרה שהתמונה מכילה פחות מ 256 צבעים, אחרת הוא הופך ל פורמט בלתי משמר. פורמט זה מאפשר מסכת שקיפות כלומר מצב שקיפות בינרי לכל פיקסל: שקוף או אטום.

	HTML
	.htm/.html
	Hypertext Markup Language. כשבוחרים בפורמט זה גימפ ישמור קובץ HTML שמכיל טבלה שבה התמונה שנשמרה. כשבוחרים לשמור כ HTML נפתח דיאלוג שמאפשר להתאים הגדרות כמו גבולות הטבלה ומלל.

	ICO
	.ico
	Icon Image File Format הפורמט של מערכות WINDOWS עבור צלמיות (icons).

	JPEG
	.jpg/.jpeg/.jpe
	Joint Photographic Experts Group פורמט המשמש רבות עבור תצלומים. הוא משתמש בכיווץ שאינו משמר (lossy), דבר היוצר איבוד פרטים, תופעה המכונה בעגה המקובלת "artifacts". ה"artifacts" מובחנים יותר בתמונות המכילות שינויים חדים בצבעוניות, ופחות מובחנים בתמונות עם שינויי צבע הדרגתיים.

	PNG
	.png
	Portable Network Graphic פורמט המשמש לעתים קרובות לצילומי מסך וגרפיקת מחשבים. מאפשר שקיפות משתנה של אזורים שונים בתמונה.

	PNM
	.pnm/.ppm/.pbm/ .pgm/.pam
	Portable Pixmap. PNM (Portable Any Map, קיצור ל ppm, pbm, ו - pgm format), PPM (Portable Pixel Map), .pbm (Portable Bit Map), .pgm (Portable Gray Map) ו- .pam (Portable Arbitrary Map).

	PS and EPS
	.ps/.eps
	Postscript Document and Encapsulated Postscript

	PSD
	.psd
	Photoshop Document, הפורמט הטבעי של אחת מתכנות עריכת התמונה הפופולריות ביותר: פוטושופ (Adobe Photoshop). בעוד שפוטושופ אינו מסוגל לקרוא קבצי גימפ (XCF) , גימפ מסוגל לייצר קבצי PSD.

	TGA
	.tga
	Truevision Graphics Adapter, הפורמט הטבעי של Targa .

	TIFF
	.tif/.tiff
	Tagged Image File Format

	XBM
	.xbm
	X Bitmap 2-bit, מפת סיביות מונוכרומטית עבור X Window System

	XPM
	.xpm
	X Pixelmap מפת סיביות צבעונית עבור X Window System


פורמטים פחות נפוצים הנתמכים ע"י גימפ

	Extension(s)
	Description

	.pix/.matte/.mask/.alpha/.als
	Alias/Wafefront תמונת Pix

	.fli/.flc
	Autodesk FLIC Animation, אנימציה

	.c/.h
	C/C Header Sourcefile Format

	.dcm/.dicom
	Digital Imaging and Communications in Medicine Image, פורמט המשמש בהדמיות רפואיות

	.fit/.fits
	Flexible Image Transport System

	.cel
	KISS Cel

	.sgi/.rgb/.bw/.icon
	Silicon Graphic IRIS Image

	.im1/.im8/.im24/im32/.ras/.rs
	SUN Rasterfile Image

	.pcx/.pcc
	ZSoft PCX Image

	.xwd
	X Windows Dump






פורמטים נוספים, שגימפ מסוגל לקרוא, אך לא לייצר

	Extension(s)
	Description

	.g3
	G3 Fax Image

	.wmf/.apm
	קובץ של WMF של מיקרוסופט

	.psp/.tub
	Paintshop Pro

	.pdf
	באנגלית: Printable Document File . פורמט נפוץ לקבצים שמיועדים להדפסה או שימור מראה המסמך בצורה סטנדרטית .

	.svg
	באנגלית: Scalable Vector Graphic . פורמט וקטורי שמיועד לתמנונות שיעברו הגדלה/הקטנה קיצוניים למשל.

	.fit/.fits
	Flexible Image Transport System


תמונות GIF

פורמט שהיה רשום כפטנט ע"י Unisys. מאחר ותוקף הפטנט פג, בגרסאות חדשות של גימפ ניתן לשמור קבצים בפורמט זה. אם הגרסה שברשותכם מעודכנת מגרסה ישנה יותר ואתם נתקלים בבעיה בשמירת תמונות כ GIF ייתכן ועדכון ספריות התמונה עבור פורמט GIF יפתור את הבעיה.



  
    GIMP/שמירה כ - JPG


סעיף זה הוא לכאורה עבור משתמשים מתקדמים, אך כל משתמש ששמר תמונה כ JPEG ומצא שהתוצאה אינה באיכות משביעת רצון ימצא בדף זה מידע רב ערך, אפילו אם רק יעיין בסעיף השימוש הבסיסי. זאת מאחר ובעת שמירה כ JPEG , להגדרות אלו יש משקל גדול באיכות התוצאה הסופית של התמונה. לכן, אם תמונה הנשמרת גדולה במיוחד מבחינת שטח, מרובת פרטים, צבעים וכו', ויש חשיבות גדולה לאיכות, כדאי לבדוק את ההגדרות ולהתאימן לתמונה הספציפית, במקום להשתמש בהגדרות שנשמרו כברירת המחדל. הגדרות שייתנו תוצאה ויזואלית מצוינת עבור תמונה אחת, לא בהכרח יתנו תוצאה ברמה טובה עבור תמונה אחרת. את התוצאה ניתן לראות בתצוגה מוקדמת תוך התאמת הגדרות, עד שמגיעים לתוצאה מתאימה ורק אז לשמור את המונה. ראו סעיף הבא. שימו לב שחלק מההגדרות המתקדמות עוסקות בתהליך ייצור התמונה, ואופן טעינתה בתכנות לצפייה בתמונות ולאו דווקא מגדירות איכות סופית של התמונה.





הגדרות בסיסיות

כאשר בוחרים לשמור תמונה כ JPEG נפתח חלון ההגדרות. בחלון זה מופיע מס' אפשרויות מצומצם כפי שמפורט בסעיף זה, וכן ניתן ללחוץ על "Advanced Options" שיגדיל את החלון ויציע שליטה בהגדרות נוספות עבור התמונה הנשמרת, הגדרות אלה מפורטות בסעיף הבא.

איכות (Quality)

שנתה זו מבטאת את האיכות הכוללת שרצויה עבור התמונה. ערך נמוך יוציא קובץ תמונה קטן יותר, על חשבון איכות ויזואלית של התמונה. ערך ברירת המחדל הוא 85, באופן כללי מומלץ להתחיל בערך זה תוך בדיקת התוצאה ולעלות כל עוד אינה משביעת רצון.

לרוב אין סיבה לעלות מעל לערך של 95, שכן הדבר מגדיל משמעותית את הקובץ בלי תוספת מובחנת במיוחד לאיכות התמונה. באופן דומה אין בד"כ סיבה לרדת מתחת לערך של 25, שמתחתיו מופיעות כמעט תמיד תופעות כגון ריצוע צבע.

תצוגה מקדימה (“Show Preview in image Window”)

אפשרות זו יוצרת שכבה זמנית חדשה בחלון התמונה, שמדגימה איך תיראה התמונה אם תישמר עם ההגדרות הנוכחיות. ההגדרות מתעדכנות בזמן-אמת, וניתן לשנות זום (הגדלת תמונה), או להסתיר את השכבה כמו בשכבה רגילה כדי לבחון לפרטים את התוצאה.

הגדרות מתקדמות (“Advanced Settings”)

לחיצה על אפשרות זו תפתח אפשרויות נוספות. הגדרות ששונו כאן יישמרו עד ליציאה מגימפ. ניתן לשמור את ההגדרות כברירת מחדל ואז הן יישמרו גם לפעם הבאה שניפתח את גימפ.

טען הגדרות ברירת מחדל / שמור הגדרות

ממש מעל כפתור Save יש שני כפתורים שימושיים:

	Load defaults - טוען את הגדרות ברירת המחדל, שהן ההדגרות שמופיעות כשאנו פותחים את גימפ. כלומר אם זו התמונה הראשונה שאנו שומרים היום, ולא שינינו שום הגדרה, כפתור זה לא עושה כלום.

	Save defaults - שומר את ההגדרות הנוכחיות כברירת המחדל שלנו. ההגדרות שגימפ מגיע איתן שימושיות לרוב המשתמשים, לכן כדאי להשתמש בכפתור זה רק עבור הגדרות שאתם בטוחים שישמשו אתכם באופן שוטף.


הגדרות המשפיעות על איכות התמונה

ההגדרות הבאות משנות ממש את התמונה, כדי להגדיל את כיווץ הקובץ. שינוי פה ישפיע על איכות התמונה הכוללת (לא בהכרח בצורה מובחנת לעין).

	Force Baseline JPEG - אפשרות זו מאלצת את גימפ לייצר JPEG שתואם את כל המפענחים (Decoders) הקיימים, לעתים קרובות על חשבון איכות וגודל קובץ, בעיקר כאשר ההגדרות מכוונות לאיכות נמוכה. לא בכל גרסאות גימפ קיימת האפשרות הזו.


	Smoothing - הגדרת ערך זה כשונה מאפס יחליק במעט את התמונה. דבר זה מפחית קצת את תופעות הלוואי של כיווץ התמונה, ועוזר להקטין את הקובץ. ערכים של 0.10-0.15 מפחיתים חלק גדול מתופעות הלוואי מבלי למרוח קצוות.


	Subsampling - גימפ מאפשר 3 מצבי "תת דגימה". "תת דגימה" במקרה זה משמעה שמיטת חלק מהמידע על צבעים בתמונה (שקשה יותר להבחין בו) לעומת בהירות (luminance). שיטה זו משפרת את הכיווץ, על חשבון איכות תמונה. הצניחה באיכות מובחנת מאוד לעתים (למשל בצבע אדום) ולעתים אינה מובחנת כלל. הפעלת תת-דגימה על תמונות שאינן מתאימות לכך תגרום למריחת פרטים, בפרט באזורים המכילים קצוות חדים. במידה והבחנתם באיבוד איכות משמעותי, ניתן לנטרל את תת הדגימה לחלוטין ע"י בחירת ערכים של "1x1x1x1" שמשמעותם המעשית היא שהליך זה לא יופעל על התמונה.


	DCT Method - קיימות 3 אפשרויות בחירה כאן. האפשרות 'Floating' מפיקה תוצאות מעט טובות יותר מאשר 'Integer' עם מחיר קטן של מהירות. האפשרות 'Fast Integer' מומלצת רק במקרים בהם מהירות שמירת הקובץ רלוונטית.


הגדרות שלא משפיעות על איכות התמונה

ההגדרות הבאות אינן משנות את התמונה עצמה, הן עוסקות במידע על התמונה ותוספות לקובץ שישפיעו על גודלו, זמן השמירה וכו' אך כאמור אין שינוי לתמונה.




	Optimize - משנה את טבלת התמונה לשם שיפור הכיווץ. מלבד במקרים בהם מהירות השמירה חשובה, אין סיבה לנטרל אפשרות זו.


	Comment - ניתן להוסיף הערה לתמונה, כגון הגדרות האיכות, או תקציר של איך התמונה הוכנה.


	Save EXIF Data - מצלמות מסוימות שומרות מידע על התמונה כמו תאריך ושעה, הגדרות ואפילו אם הפלאש היה מופעל או לא. בתמונה מקורית שלא היה מוטבע בה מידע זה ופתחתם אותה באמצעות גימפ, אפשרות זו תופיע באפור ותהיה בלתי פעילה.


	Save Thumbnail - פורמט JEPG מאפשר שמירת תמונת אצבע של התמונה המקורית בקובץ עצמו. אפשרות זו לרוב אינה נחוצה כיום, מאחר ורוב התכנות שמשתמשות בתמונות אצבע מסוגלות לייצר אחת לעצמן, מה גם שתמונת אצבע מוסיפה כמה קילובייט לגודל הקובץ.


	Progressive - אפשרות זו משפיעה על אופן טעינת התמונה בתכנות לצפייה כמו דפדפנים ותכנות מצגת. תמונה הנשמרת עם אפשרות זו, תיטען בדרגות איכות הולכות וגדלות עד להצגת התמונה באיכות הסופית. האפקט דומה לעתים ל"כניסה לפוקוס" על מחשבים אטיים. שמירת תמונה עם אפשרות זו גם משפרת את הכיווץ. כאשר אפשרות זו אינה פעילה התמונה נטענת בצורה הרגילה - שורה אחרי שורה מלמעלה למטה.


	Restart Markers - אפשרות זו שימושית עבור קבצים כאשר יש אפשרות של תקלות שיביאו לפגימה בקובץ, למשל תמונות המיועדות להורדה משרתים שהתקשורת אליהם ברמה ירודה. במידה והקובץ ייפגם, תמונה שנשמרה כך "תתקלקל" רק בצורה חלקית, עד סמן האתחול הבא בקובץ. ערך גבוה כאן יגדיל את תכיפות הסמנים בקובץ, וגם יגדיל את הקובץ עצמו. במידה ויוגדר לא להשתמש בסמני אתחול כלל והקובץ ייפגם, כל התמונה תאבד.
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דיאלוג השכבות של גימפ





שכבות בגימפ הן כלי רב כוח אך פשוט בבסיסו, שמאפשר לעשות דברים רבים. הדרך האינטואיטיבית ביותר להסביר מה הן שכבות היא אולי זו: נסו לדמיין משטחי זכוכית מונחים אחד מעל השני, שביכולתכם לצייר על כל אחד בדרגת שקיפות חלקית או מלאה, להחליף את הסדר ואף להוציא משטח זה או אחר מהערימה. התמונה הסופית היא מה שתראו אם תעמדו כשפניכם אל ערימת המשטחים.


[image: ]



תמונה 2: הוספת דיאלוג השכבות כטאב לארגז הכלים






חלון ניהול שכבות (Layer Dialog)

לחלון ניהול השכבות 2 מצבים: כטאב בחלון ארגז הכלים, או כחלון נפרד.

	לפתיחת החלון כטאב: בחלון ארגז הכלים, יש להצביע על החץ הקטן כפי שמוצג בתמונה 2 ולבחור Add tab > Layers. הטאב ניתן להסרה או הפרדה לחלון נפרד.

	לפתיחת דיאלוג השכבות בחלון נפרד: בתפריטים שבראש חלון התמונה יש לבחור: Windows > Dockable Dialogs > Layers


איך מתחילים

פתחו את דיאלוג השכבות, והוסיפו שכבות כרצונכם. שימו לב שפעולות עריכה, פילטרים ורוב כלי העבודה יפעלו רק על השכבה או השכבות הפעילות.

שקיפויות

שנתת השקיפות (Transparency) משנה את דרגת השקיפות שבה מוצגת שכבה מסוימת, מבלי להשפיע על ערוץ האלפא הפנימי של אותה שכבה.

מסכת שיכבה (Layer Mask)

שכבת מסיכה היא שכבה בשחור לבן, ששולטת באופן מקומי בדרגת השקיפות של התמונה. זהו אמצעי שימושי להסתרה או הצגה סלקטיבית של חלקים מהשכבה בלי הצורך למחוק את החלקים האלה הלכה למעשה. להוספת שכבת מסיכה בתפריט הראשי בחרו "Layer > Mask > Add layer mask". בחרו איזה סוג שכבה שברצונכם ליצור.

שימוש במסכת שיכבה לעריכה סלקטיבית של תמונה

מסכת שכבה שימושית ביותר לעריכת חלקים מתמונה תוך הגנה על חלקים אחרים. כדי לעשות זאת, שכפלו את התמונה המקורית לשכבה נוספת, ובצעו את השינויים על השכבה התחתונה מבניהם. כעת הוסיפו שכבת מסכה בצבע שחור לשכבה שנשארה נאמנה למקור. על שכבה זו השתמשו במברשת בצבע לבן, כדי לחשוף את החלקים המקוריים היכן שהם רצויים לכם. אזורים בשחור בשכבת המסכה יקבלו שקיפות מלאה, ואזורים בלבן (RGB 255,255,255) יישארו אטומים לחלוטין (כלומר לא שקופים כלל).
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דיאלוג הנתיבים של גימפ





נתיב בגימפ הוא קו או כמה קוים שניתן לבצע עליהם או בעזרתם פעולות רבות. ניתן למשל לבחור את אחד מכלי הציור כמו מברשת הצבע או כסת הדיו, ולצייר לאורך נתיב. ניתן לבצע זאת, לשנות את צורת הנתיב ולחזור על הפעולה. ניתן לייצר נתיב מקווי המתאר של צורה או אותיות, או לפרוס מלל לאורך נתיב קיים. תמונה יכולה להכיל מספר בלתי מוגבל של נתיבים. הנתיב הוא ישות בפני עצמה ואינו מוצמד לשכבה זו או אחרת של התמונה. אפשר להציג או להסתיר נתיבים לפי הצורך. בקצרה, למרות שאפשר לעבוד עם גימפ בלי להכיר את הכלי הזה, ואף לייצר עבודה ברמה גבוהה, הוא למעשה אחד מ"כלי הליבה" שלו. בעת העברת תמונה לאחד מהפורמטים ה"ניידים" (כלומר הפורמטים שמשמשים להצגת תמונות ולא לעריכתן), הנתיבים אינם נשמרים ואינם נראים.
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תמונה 2: הוספת דיאלוג השכבות כטאב לארגז הכלים





חלון ניהול נתיבים (Path Dialog)

לחלון ניהול הנתיבים 2 מצבים: כטאב בחלון ארגז הכלים, או כחלון נפרד.

	לפתיחת החלון כטאב: בחלון ארגז הכלים, יש להצביע על החץ הקטן כפי שמוצג בתמונה 2 ולבחור "Add tab > Paths". הטאב ניתן להסרה או הפרדה לחלון נפרד

	לפתיחת דיאלוג הנתיבים בחלון נפרד: בתפריטים שבראש חלון התמונה יש לבחור: Windows > Dockable Dialogs > Paths





איך מתחילים

אפשר ליצור נתיב חדש במספר דרכים, הדרך הישירה יותר היא בחירת כלי סימון הנתיבים מארגז הכלים וציור נתיב ביד חופשית. דרך אחרת היא הוספת מלל לתמונה ואז לחיצה על "Path from text". מיד עם הוספת נתיב הוא יופיע בחלון ניהול הנתיבים.
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דיאלוג הערוצים של גימפ. מודל צביעה RGB, כל הערוצים נראים ופעילים
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דיאלוג הערוצים של גימפ. מודל צביעה RGB, הערוץ הירוק מוסתר (אין סמל עין בשורה שלו בדיאלוג)





כלי הערוצים ערוצים בגימפ דומה מאוד לכלי השכבות. בדיאלוג הערוצים, כל שכבה מייצגת צבע בסיס אחד לפי מודל הצביעה הנוכחי (RGB, HSV או CMYK). ניתן לבחור להציג כל צירוף של ערוצים. ערוצים פעילים מסומנים באפור בדיאלוג. ניתן להציג ולערוך רק מבחר מסוים מבין הערוצים בזמן שהתמונה כולה מוצגת. בחירה אילו ערוצים נראים ואילו מוסתרים נעשית באותו אופן שמציגים ומסתירים שכבות. פשוט הקליקו על השכבה וצלמית של עין תופיע או תיעלם, מייצגת את מצב הנראות של הערוץ. יש לזכור שניתן לערוך ערוצים (או שכבות!) גם כאשר אינם במצב נראה, דבר שיכול להוביל לעבודת שחזור רבה אם בטעות בחרתם את השכבה או הערוץ הלא נכונים בעת העבודה.

בזמן כתיבת מדריך זה גימפ תומך רק ב 2 מודלים של צבע: (RGB (Red, Blue, Green ו - ( HSV (Hue, Saturation, Value . מודל CMYK אינו נתמך באופן טבעי ע"י גימפ, אך קיים תוסף שמעניק פונקציונליות מסוימת עבור מודל זה. ניתן להוריד את התוסף הזה מכאן:

http://www.blackfiveservices.co.uk/separate.shtml

בנוסף גימפ מאפשר הוספת ערוצים מותאמים שמאפשרים שימושים מתקדמים בעריכת תמונה.

פירוק תמונה קיימת לערוצים לפי מודל צביעה: בגרסה 2 של גימפ נמצא תחת Color > Components > Decompose .
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מיקום פעולת Decompose בתפריטים שונה בין גרסה 1 של גימפ לגרסה 2. כאן מוצגת גרסה 2





בחירת מודל הצביעה הרצוי:
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מודל הצבע לפיו אפשר לפרק בפעולת Decompose
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[image: ]



פתיחת דיאלוג השכבות של גימפ כטאב בארגז הכלים





חלון ההיסטוריה

לחלון ההיסטוריה 2 מצבים: כטאב בחלון ארגז הכלים, או כחלון נפרד.

כמו בכל פיסת תכנה מודרנית, גימפ מאפשר "חזרה לאחור" של שלבי עבודה. אף על פי כן, יש כלים, כמו כלי בחירת קידמת תמונה, שחלק גדול מהעבודה שלהם נחשב ל"שלב ביניים", וכאשר מבקשים לבטל את הפעולה, נאבד חלק גדול מהעבודה. לאחר שאמרנו זאת, נחזור ונרגיע שברוב המקרים אנו בטוחים בידיו של דיאלוג ההיסטוריה, שמציג לנו רשימה לינראית של הפעולות שביצענו, ואף מספק איור גרפי של כל פעולה, לסקירה מהירה ונוחה של הרשימה. אורך ההיסטוריה שגימפ שומר ניתן, כמו תכונות רבות שלו, להתאמה. כך שאם אתם עובדים על מחשב חלש יחסית ומחזיקים יישומים רבים פתוחים, תוכלו להקטין את כמות הפעולות שנשמרות ואולי לשפר מהירות התכנה. ולהפך אם עומדים לרשותכם משאבים רבים ואתם עוסקים בעריכה מורכבת. ובכן, הבה נפתח את חלון ההיסטוריה כטאב בחלון ארגז הכלים, ונגדיל את הזיכרון המיועד לשימוש דיאלוג ההיסטוריה, כלומר נגדיל את מס' הפעולות הנשמרות שגימפ יוכל לשמור עבורנו!

פתיחת דיאלוג ההיסטוריה

פתיחת חלון ההיסטוריה כטאב מוצגת בתמונה הראשונה משמאל למעלה. אם ברצונכם לפתוח את חלון ההיסטוריה בנפרד, תוכלו לפתוח אותו כטאב ולגרור אותו החוצה מארגז הכלים עם העכבר, או לפתחו כך : Window > Dockable dialogs > Undo history .
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חלון ההגדרות של גימפ 2.6 על אובונטו





הגדרת מס פעולות הנשמרות בהיסטוריה

פתחו את חלון ההגדרות, והתאימו את הערכים לפי הרצוי לכם. שימו לב שערכים נמוכים או גבוהים מידיי עשויים להגביל את תפקוד גימפ ולרוב אין סיבה לשנות את ברירת המחדל. חלון ההגדרות נמצא תחת Edit > Prefernces. הוא נראה פחות או יותר כמו שמוצג בתמונה משמאל, ייתכנו הבדלים בין גרסאות ומערכות הפעלה.






  